H265 "Main10" constant bitrate does not work

Selecting the below output settings results in a bitrate much lower than what is selected (1.6mbps vs 24mbps for my clip), to the point of banding and artifacting. This only occurs with “Main10” and does not occur with “High” profile of H265.

image_2024-07-08_145436311

Solution : I’ve checked the export command and changed "-b:v" "24M" to "-rc" "cbr" "-b:v" "24M" which now forces ffmpeg to adhere to the selected bitrate. Banding and artifacting is now fixed as a result.

TLDR; add "-rc" "cbr" to ffmpeg command to force use of constant bitrate

Edit : This issue is with both AMD and Nvidia GPU’s, specifically 7900xtx and 3070ti

3 Likes

Topaz Video AI 5.2 still had not fixed this.
However, the export command solution did not work for me. Though the banding is fixed, the upscaled clip is not playable.

same happened. I said before again and agian. but not solved. My pc is amd 5900x with nvidia rtx 4900.

@hyun.choi @ko-lun.chen I’ve found a better fix than changing the command line everytime.
Go to directory C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models and open file “video-encoders.json”

Go to line 394 (now 415 after 5.2.1) and change the line to include -rc cbr
Full line being "cbr": "-rc cbr -b:v <CONST_BITRATE_VALUE> -preset p6",
Example below

That fixes constant bitrate for both Nvidia and AMD GPU’s.
AMD using NVENC is a separate issue. . . but it works.

Note : Mediainfo will show video bitrate incorrectly (tagging issue?), but the overall bitrate will be correct.

3 Likes

thank u so much for kind and good solution!!
note: sadly to me, It wasn’t resolved…

Not sure but this may be related. I’m way back on Version 3.012 and I’ve noticed recently H265 “Main10” has gone from encoding at around 15 Mb/s (Auto) for DVD to 1080p right down to 4Mb/s which is unusable. Even manually setting bitrates makes no difference or which model I use. Waiting for a solution as right now the program has become useless.

Replacing the line in “video-encoders.json” works for me. I’ve enhanced a few clips. The bitrate is constant as set. I guess Video AI might not work well with the recent Nvidia drivers. When I found this issue, I went back to Ver. 4s and Ver. 3s. But the issue remained. I did not roll back to the older Nvidia drivers though.

1 Like

5.2.1 still not fix it :tired_face:

I sent the “logs for support” to the team last week. Hope they will fix it in the next release…

1 Like