Grid Artifacts IN Topaz Photo AI

I still have Grid Artifacts in Topaz Photo AI V1.1.6 on many pictures proceesed.

Its the same since 1.0.1

Can i remove or prevent this or is it a bug in the sotware


I have the same issue even with Topaz Photo AI 1.2.7, on a Macbook Pro M1 Max with the Lightroom Classic plugin.
I tried to set the AI processor to CPU (as it was suggested on another thread) but I still get the grid pattern.
It’s VERY annoying to say the least and it’s really a problem as the grid is visible on some photos, even without any sort of editing.
Very disappointing…

What surprises me the most is that this “Grid pattern artifacts” problem exists since version 1.0 and that even worse the problem also exists with Topaz DeNoise while Topaz Lab seems to sleep on the switch to fix it.

This week I had to start a new contract because all my photos processed with Topaz Photo had “Grid pattern artifacts” more or less visible on the processed images.

I confirm that this problem is not caused by a problem with my images, I reprocessed all the same images with Luminar Neo to submit my contract to the client and none of them displayed “Grid pattern artifacts” once processed in Luminar Neo.

Afterwards, during a whole evening, I redid tests with a sample of 10 images to test with all the other softwares I own;

Lightroom Cllassic
ON1 PhotoRaw
Luminar Neo
ACDSEE Studio Ultimate

None of the images processed with all these softwares show “Grid pattern artifacts”, so I’ll have to put Topaz Lab aside in my work flow until this bug is fixed.

The ball is in Topaz Lab’s court

I just bought & downloaded Topaz Photo AI 1.3.1 and am having the same problem, edited images have a white grid artifact. On Windows 10, not even editing in LR. This is making the images useless, what is the solution? Read in another post to RAW remove noise first then Enhance via separate processes, this seems to help but is a longer process.

Just adding my example to this issue to try to get a little more attention. Starting with a Sony RAW, I processed using Autopilot for denoise, cropped, and upscaled to 2x which obviously turned on Enhance.

1 Like

Hello all. Thanks for sharing the image examples. I shared this with my team with the examples included and asked if we have any solutions we can implement ASAP since it prevents you from pairing two of the main features in Topaz Photo AI, which is Raw Remove Noise and Enhance Resolution/Upscaling.

If you have the original RAW files that I can test with I can pass those along to my team as well so we can confirm if we can fix it.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Thank you very much Lingyu, I have uploaded my original, look forward to your response.
Admit I’m new to Topaz, maybe there is something I can do differently (but not a 2 step process), and I would like to batch edit. But locating this unresolved bug in the forum so easily is concerning, if this cannot be resolved I will need to request a refund.


Thank you @mark.belanger, Lingyu hasn’t had a chance to look at these quite yet but he’ll report back as soon as possible :slight_smile:

denoise is creating a grid pattern in the sky.

Steps to reproduce issue:

  1. Removing low image noise.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

I am also seeing this when processing RAW files with Autopilot set to Strong RAW Noise Reduction.
I am using the Windows version 1.3.2 and Canon compressed RAW files (.cr3):

Removing the sharpen autopilot setting does not fix the problem, but changing to Normal RAW Noise Reduction does.

I have been getting grid pattern artifacts ever since 1.1.9. Every time I try and update from 1.1.9. Guess I’m stuck with 1.1.9

I have uploaded my original RAW to your Dropbox file for you to look at. Please note that I am not using the Enhance Resolution/Upscaling. It seems to just be the Strong Raw Noise Reduction that is causing the grid problem for me.

Adding another instance here. Renders Topaz Photo AI completely useless on any image with large areas of blank space - in skies, for example. That said, it seems to occur more in areas with some shadow tones.

I have found the culprit to be the strong settings in either noise or sharpening. If I manually use Sharp - Standard and Noise - Normal, the the grid seems to be either very minimal or not there at all.

Notes: No upscale. Nikon Z7II. Capture One Pro. Mac Ventura. Topaz 1.3.3
Open with: Saved as DNG from Topaz. Also appears when saved as TIFF from Topaz.
Also happens when I use Edit With from Capture One.

I do have a workaround. If the grid is caused by Raw Remove Noise:

  • Convert RAW image to non-RAW such as TIF.
  • Import TIF to Topaz Photo AI and process as you normally would.

If the grid is caused by Raw Remove Noise and Enhance Resolution used together:

  • Use Raw Remove Noise OR Enhance Resolution instead of both at the same time.
  • Process with one, convert the file to non-RAW, process a second time with the other.

We are currently about to train a new Raw Remove Noise model which should address the grid pattern issue. The AI models take some time to train and refine but that should be out soon.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.