GPU not being used on Mac M2 Pro with 3.3.9

[If you are posting a new bug, please include the following]

  1. GPU not being used. Should be using 70-90 percent
    2.Mac Mini M2 Pro
  2. Your log files (Help > Logging > Get Logs for Support)
  3. Any screenshots as necessary
    logsForSupport.tar.gz (400.3 KB)

[Please be sure to have searched for your bug before posting. Duplicate posts will be removed.]

The M2 machines use the neural network and the CPU/ GPU consumption will not be as accurate when looking at the activity monitor.

Also, some models will use more of less or the cpu/gpu, etc. You will want to look at Topaz Video AI and FFmpeg when looking at the activity monitor if you are not already.

Try reducing the max memory to 10% and see if that makes any difference. I have found that for upscaling SD sources, the GPU is hardly used unless it is “forced” to by reducing the max memory.

Topaz and / or Apple seem to think that the user should wait much longer than necessary for the sake of “power efficiency”. When the GPU is being used at near 100%, performance is increased significantly (by around 50%). There is no sign that Topaz have any intention of making changes to get the most out of Apple Silicon. That’s why I’ve given up waiting and created my own scripts for upscaling SD (using clip “stacking”). I get 60% speed increase over what can be achieved in TVAI alone.



Okay. I always have my activity monitor running. In this case is a big crop in of a 4K video with auto crop stabilization and 3 jitter passes, upscaling back to full HD and Proteus enhancement. Ffmpeg typically uses 300% of cpu and I’ll see why it’s not using gpu like it seemed it use too. But maybe it was the extreme crop.

I’ve done more tests and I always have activity monitor open when I’m working on video. It was much higher before the last update. If I re-install and older version I might be able to confirm. But it should be in the 70-90% range normally when I do my usual topaz process of auto crop stabilization with enhancement.

Yes, that would be great is you could share stats from the version you were seeing usage in the normal range. I would also need logs- can you double check the FFmpeg commands to make sure that they are the same?

Okay I tried another time-lapse sequence with less of a using the Auto Crop Stabilization preset from 5K to full HD out, but the difference being that I was not doing a huge crop in this case and the GPU acted as expected using about 70%. So, it is only if I do a large crop below FHD and then choose to upscale back to HD that the GPU doesn’t engage with all other settings the same.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.