GigapixelAI Now Crashes On TIF Save with v4.2.2 Update

Well, I never had this problem before they “fixed” it. With the latest update I now can’t enlarge my TIF files without it crashing before it saves. I can save them as JPG files, but not as a TIF.

Yes, I’ve already turned in a ticket…

If you need us to look at the question here please add the following information:

  • Original input file details, including color profile, compression and size in pixels
  • Click Help-> Graphics info., press the Copy button and paste the information here, then
  • Parameters used for enlarging
  • Parameters for saving the result.

For the last two items upload a screenshot please.

The issue with TIFF images was the inability to open certain types of image not saving them.

It opens, runs the preview and goes through the enlargement process. When it then tries to save the file it starts to create it and writes about 8 bytes then crashes the program, leaving a fragment of a TIF file with the new name (originalname-edit) behind.

File Info:
sRGB, no compression, Interleaved Pixel Order, 8 bit, 1024 x 1024 TIF.

Program Info:
Application & Version: Topaz Gigapixel AI Version 4.2.2
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 980/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 425.31
CPU RAM: 16314 MB
Video RAM: 4096 MB Total, 3616 MB In Use
Preview Limit: 6190 Pixels

Enlargement Parameters:
Scale, 4X, Manual, Suppress Noise 0.66, Remove Blur 0.40

Conversion Type:
Convert File Format No

I just tried it with a 24 bit TIF with everything else the same and it works as it should.


As you are no doubt aware the changelog for v4.2.2 lists only one change, being “Fix crash on export with TIFF files caused by metadata issue”.

I’m not currently experiencing any issues with TIF/TIFF exports in any of the compression formats (none, LZW, ZIP) using Gigapixel AI 4.2.2 using source images from a number of different cameras with different metadata, however in one of the very early versions of Gigapixel I did experience crashes exporting TIF/TIFF files. The crash occurred right at the end of the up-sizing process, right where I suspect the disk write should have started. At that point Gigapixel AI simply shut down.

It might be informative to try deliberately removing the metadata from a copy of one of the source images that is crashing, and then try enlarging that to maybe get an idea if the problem is metadata related, and perhaps also trying a test using a Resize by 0.5x with the same source image to see whether it might be size related.

Just a thought …

I also have no problems, the only thing I can see is that the NVIDIA driver is a little old as the current version is 431.60

The other thing is that you should make sure you have set your virtual memory, paging file size, using manual settings of Initial Size equal to your RAM to a Maximum Size of double your RAM.

Also make sure you save to a local disk not a network drive.

Thanks for the suggestions!

These may not be your typical TIFs. They started out as DDS files and were saved in their most simple uncompressed form in Photoshop. As far as metadata, they have none, other than the image related header information about size and bit depth.

The discovery last last evening that the 24 bit versions can be successfully saved as TIFs by Gigapixel AI gives me a path forward. I just need to not save any of them as 8 bit when converting from DDS.

When I turned in the help ticked I provided Topaz with an example file, so perhaps a future update will include the capability to handle this particular form of TIF.

As far as updating the Nvidia driver, this is the newest one I can run without incurring trouble with the system bogging down (mouse lags for seconds at a time that never goes away) after my Gsync screen wakes up. The only thing that clears it is to reboot, if you can ever get the system to maneuver over to let you click on the restart icon. I’ve traced that to WDDM 2.6 incompatibility with my older GTX980 and needing to stay on Win 10 1803 versus a newer card on 1903 that the newer drivers are targeted at. Any attempt to update past 1803 leads to a repeating failure to install that seems to be related to the hardware on my motherboard (Strix Z27DH) no longer being supported by Win 10.

BTW, Gigapixel AI has saved me a great deal of time of the past few months. I’ve been upgrading the graphics for an older flight sim by increasing the 3D models texture sizes from 1024 to 2048 or 4096 to eliminate visible aliasing along the panel lines and text markings. The process used to be to just enlarge the DDS files directly in Photoshop, and then hand retouch everything. It took about an hour, and the image still ended up a bit soft and blurry from the enlargement. Now I can get a great looking result that only needs minor touch up, in a matter of 5 minutes or so. This particular sim has thousands of these files, so this has been a Godsend. The most time consuming part of the process now is to convert the DDS to TIF, and then back to DDS again after Gigapixel AI has done its magic.

1 Like

I noticed in your earlier post that you had Convert File Format set to No.

Because the crash it not occurring until the export file write part of the process, maybe Gigapixel AI is able to read and process your files, but not save them in the original format.

Perhaps if you set Convert File Format to Yes, and then set the format to one of the standard Gigapixel TIF/TIFF options, it might be able to complete the process.

Again just a thought …

I had a reply from Customer Support today instructing me to delete the program and reload it from scratch again.

I did exactly as they instructed, and it made no difference in the ability to process these 8 bit TIF files with Gigapixel AI.

What I’ve discovered is that since these started life as Index Color ARGB format 8 bit DDS files that are converted into TIF files with Photoshop they are not currently compatible with GigapixelAI.

They can be opened, the image previewed, and the enlargement process works, but when it tries to save it always produces an error that crashes the program, leaving behind a properly named blank TIF that is 8 bytes in size.

I’ve tried no conversion, as well as all of the various forced conversion process options related to TIF files with no success.

Converting the TIF into a JPG as part of the enlargement process works just fine.

If I convert the Index Color DDS to RGB color format before converting it into a TIF, then everything works properly, and the file is successfully enlarged and saved as a TIF without crashing the program.

Perhaps not being able to save 8 bit Index Color TIF files is a limitation in the supported file types list that I missed?

I’ve discovered these two work-arounds, so it’s not the end of the world, but it would be nice if they would eventually add this capability.

I thought that Index(ed) Color was a technique using compression and color lookup tables more than an ICC Profile as it is used for managing colors in digital images in a limited fashion … to save memory, file storage and speed up display refresh etc.

I remember that Topaz didn’t support WideGamutRGB but they did when asked so you might see if they can apply indexed color to the ICC Profile

One thing I tried was to save the DDS to TIF conversion without any ICC profile, but it didn’t make a difference. My thinking was that Gigapixel AI was being confused by the combination of an 8 bit Index Color scheme and an associated ICC profile.

Gigapixel could tell if there was an ICC profile in the TIF or not, so it was parsing the file successfully. It appears that it was simply a matter of there not being a sub-routine available to save the Index Color scheme, and there was no error check before it tried, so it crashed.

The Help Desk confirmed that they currently do not support any Index Color formats. They’ll update the supported files list to make that clearer, and will consider adding it sometime in the future.

1 Like