Gigapixel v5.1.6

We’ll be swapping out the back-end in Gigapixel in the next few months, once it’s been completely tested and stable in VEAI. This won’t be an AI model change or anything, but strictly performance. This should be a massive speed improvement to the current processing times - conservatively speaking, at least 2-3 times as fast.

It’s a huge change so will take quite a bit of time to implement and work out the kinks. I’ll keep everyone posted on progress though as we get closer to seeing it in GP.


VEAI (generally speaking) uses a technique similar to something called temporal anti-aliasing to achieve some of its frame-stability and crispness. It basically uses frames before and after the current frame to infer what certain things in the current frame should look like.

We’ve played around with similar ideas in Gigapixel, but ultimately scrapped them because it’s not the focus of GP and the architecture of the product doesn’t support it easily. We are looking at ways to reduce some of the artifacting you see from old photos, however.


I’m not sure I understand - are you noticing differences in the entire image with face refinement on or off, or is this just a difference between the Image Type modes? It’s hard to say what exactly’s going on, but the two different modes are two different AI models trained on different sets of images, so there’s definitely going to be differences (major and more subtle) between the two.

I guess it must be because they are different AI models but I see differences in the overall result and with the faces where there is a general overall “softness” using face refinement compared to not.

It seems that man-made gives a far better result without face refinement especially because there is less softness in both the faces and the image overall.



Great to see this red issue has still not been fixed! If anything it’s gotten WORSE as there’s now even more red areas in the processed image.

Starting to think the developers just don’t care about this problem despite being made aware of it.

1 Like

Please refrain from posting like this as it is totally unnecessary, you should read this thread for guidelines how to use and act on this forum …

1 Like

Wow, really Don? So it’s totally unnecessary to voice my concern that a longstanding issue has not been resolved and any time I (or other users) have brought it up, we’ve gone ignored by @taylor.bishop?

Don, I LOVE Gigapixel and the work the Topaz team does. But I don’t think it’s right for update after update being pushed forward without the developers taking a serious look at what could be causing this red problem with releases beyond v4.4.5 .


Update v5.1.6 has broken Photoshop integration for me. When I run Gigapixel from Photoshop, Gigapixel creates a new layer but opens and close immediately with any interaction. I tried reinstalling Gigapixel a couple of times but have been unable to resolve the issue.

Please run as a standalone and go to Help-> Graphics info., press Copy and post the info here please.

You can voice your concern but keep it reasonable and to the point, sarcasm and cynicism are really not useful in this situation. I assume you have also raised a support request with a copy of the image and details of your setup.

If you would like me to have a look at this for you, please either post a link to the original … or you can send me a link to the original on a file sharing site in a PM, then tell me what parameters you are applying to the GigaPixel processing … a screenshot of the setting and the Save panel on the output would suffice if you are running as a standalone or just the settings panel if you are using as a plugin. If you are using as a plugin please quote the host.

Also open the preferences and post a screenshot of those here along with the technical details which you can find by going to Help-> Graphics info. and press copy.

1 Like

Hi AiDon,

Allowed graphics memory consumption is set to medium;

Application & Version: Topaz Gigapixel AI Version 5.1.6

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 980 Ti/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 452.06

CPU RAM: 65411 MB

Video RAM: 6144 MB

Preview Limit: 7995 Pixels

Expressing frustration in a harmless fashion is also important feedback. He wasn’t being unreasonable in what he said. I have to give you kudos though, for not deleting his post.

1 Like

Can you try setting processing to CPU / OpenVINO to see if that works.

I’m sorry AiDon, but as @johnnystar said, it is frustrating.

Here’s the original image:


Save settings:

Graphics Info:
Application & Version: Topaz Gigapixel AI Version 5.1.6
Operating System: Windows 7 SP 1 (6.1)
Graphics Hardware: GeForce GTX 780/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 431.60
CPU RAM: 40943 MB
Video RAM: 3072 MB
Preview Limit: 5157 Pixels

For what it’s worth @rayinsanmiguel-15486 stated he tested it and got the same results:

Neither setting made any difference, I’m running a Threadripper CPU. Everything was working fine in 5.1.5 until I updated to 5.1.6 last night. Going to try reinstalling Photoshop and GigaPixel again…

…Reinstalled Photoshop and Gigapixel but still have the same issue.

I ran a few tests on your original image.
First I was able to replicate the issue with a wide variety of settings.
Then I tried to crop down to just the Blue area to see if the red was being assumed from the AI looking at the overall image reflections, and the issue was still there.
Then I inverted the color (the blue became amber) and no color shift happened with enlargement.
Then I used selective color to reduce the magenta component of your blue making it more cyan, and no color shift happened with enlargement.

I enlarge a lot of game textures, and often find that it’s adding cyan artifacts around red areas like warning sign text.

Perhaps their training images had chromatic aberrations that needed correction. Now it seems like the AI is looking for those where none exist, and ends us adding its own in by accident.


This is what I surmised.

Photos need to rely more on AI interpretation, and Microblocking would not normally exist.
Thought I might be able to contribute something useful, but I have nothing.
Will do another run with Gigapixel for video trying @robertvarga settings.

I Put a lot of work into using VEAI GC, so switching back is no issue.
For general feedback purposes: I hard limit brightness, reduce shadows and contrast before processing, and re-adjust after processing.

If you’ve not already done it, I would open Gigapixel in standalone mode and reinstall the plug-in, which I believe is under the ‘Help’ menu. Sorry if my suggestion is redundant, just trying to help.

Thanks for the suggestion but there doesn’t appear to be a way to reinstall the plug-in from any of the menus in Gigapixel. Besides I did a clean re-install of both Photoshop and Gigapixel earlier today. Looking at the Gigapixel log files there appears to be a new event called onLoaded which doesn’t appear in the logs from Saturday prior to me applying update v5.1.6. and this is where Gigapixel is failing.


The image I was trying to load into Gigapixel from Photoshop was using the Adobe RGB colour space. Once I converted the image to sRGB the image loaded into Gigapixel without a problem.

Thanks to everyone that tried to assist me with my issue.

Exactly the same problem for me…
My image was a “Print Screen” so already sRGB, but just changing to something else made it work with PS.