Gigapixel v4.4.4 crashes on file loading

Hi All

I have been using v4.4.3 without issue and finally decided to install v.4.4.4

All seemed well after installing so thought I would just try a random jpg file to open it in Gigapixel…

It loads it and the Preview starts to build but a few seconds in at 1% of the build the program closes down???

TIA for your thoughts and insight :slight_smile:

PS FWIW as per the instructions about installing v4.4.4 I used the new online installer download. It would not let me do an overlay install so I installed it into its own new folder. And then also via W10 apps ran the uninstaller to remove the older v.4.4.3

PPS Though Use Max quality AI models had been “Yes” in v4.4.3 I turned it off but this made no difference!

Firstly, what is the file you are trying to load i.e. pixel dimensions, and how large are your trying to make it.

I would download the installer again, right-click and choose run as administrator, and see if that completes the correct install by removing the the current install and re-installing. There may be issues because of items left over with 2 installs on the hard disk. In future I would advise that you run all installers as administrator and, if other copies exist, remove them first.

if this doesn’t work please raise a support request at the main website.

Hi Don

OK thanks for the heads up.

I will have to do that in the morning now as 2am here :slight_smile:

PS I am also in process of updating Sharpen AI and that also did not want to do an overlay install…so going into a new folder. I think I had best abort that install for now !

You must do an overlay install as that is part of the install process, otherwise uninstall first.

Sorry I must have misunderstood what you said above about uninstalling first???

In answer to the test file size it is 2952x1968px

The resize was what I had used last time and was by width @ 3600px

1 Like

Ok and update bit of info.

I spotted that Face Refinement was “on” by default so turned it off…preview loads and file processes within seconds (only a modest size increase).

Non too sure what to make if that behaviour bearing in mine that v.4.4.3 was fine though I cannot recall what Face Refinement was set to on that???

PS in the Changelog v4.4.4 was supposed to fix:-
Fixed an issue that caused Gigapixel AI to crash with face detection turned on

Ok, can you raise a support request to let the engineers know that face refinement is causing an issue for you. Also make sure you tell them if there was a face in the image and upload the image with the support request if you don’t mind.

Ok will do so in tomorrow.

For the record it was of birds in a nest…so faces yes but not human :wink:

Just tried as a quick test of one with single flower bloom…it crashed with Face ‘on’ !

Thank you :blush: report it like that thanks.

Hi Don

I reported it together with a pointer to this thread plus the two test files and the DXDiag report.

And though not exactly related to the issue re: updating Sharpen AI I added this for Emily’s attention:-

Please forgive me adding an unrelated though relevant info for you about your installer process.

I have also just updated my Sharpen AI from version 1.3.0 to 1.4.4

I, as advised on the changelog, downloaded the online installer rather than updating from the GUI (same method of updating the Gigapixel ~ though note in my User to User forum thread an oddity about that update). I ran the installer with Admin permissions and browsed to the folder of v1.3.0 installation i.e. Topaz Labs > Topaz Sharpen AI but it would not accept that folder!

Pulling back to ‘Topaz Labs’ it advised me that it would delete the contents. When finished it had installed v.1.4.4 into “Topaz Labs” folder leaving the older ‘Topaz Sharpen AI’ folder intact with its still launchable v.1.3.0 available.

FWIW I have done overlay installs of other software in the past and never seen this behaviour???

Yes I saw the changelog, let me test it and get back to you. Did you use the links in the actual changelog?

Hi Don

Yes, in both Giga and Sharpen I used the appropriate Windows links in the Changelog page(s).

It works fine for me, the folder you quote must have the Disk ID, e.g. C:\Program Files\Topaz Labs\Topaz Sharpen AI but if you search for the folder using the Browse button you get the following dialog when you continue:


But if you then change one character in the directory for installation it will then carry on and install properly such as this:


I will report it as it probably occurs for all installers as you have seen on the two.

Hi Don

Thanks for your tests and insight.

I have always used a bespoke drive & location for installing programs and all previous non DxO program installers have always found the installed program path! I wonder why the DxO installer does/did not find the correct prior installation path :frowning: It looks like it is failing to find the current install and reverting to a fresh install default path.

I cannot recall now if I tried manually amending the path in the field you show…I might have done so at first on one of them but did not change the ‘case’ of the drive letter to lower case. Of note I did get the same message in the first capture you show :slight_smile:

Clearly(?) there is an oddity in the implementation of the installer???

What with the way it forced me to install Giga into a different folder and the strangeness of the Sharpen update install…it might make sense for me to clear out the lot and do a completely fresh installation of both. But is there a recommended method of making sure that all old traces are removed to avoid conflicts and possible future problems???

When you report this can you please ask for their insight in regard to such a tidy up/uninstallations and then reinstalling?

(NB looking at W10 Apps & Features it seems that the only Sharpen listed is v1.3.0 with nothing showing for v1.4.4 Second note ~ on my Start menu the only entry under Topaz Labs is v1.3.0 and no sign of Giga???

As for Giga I have two entries on the Apps & Features listing ~ one is v.4.4.4 and other is a remanent that was left behind following the older versions uninstall!

Ideally I would like to get both these installations tidied up just in case I have issues caused that could be irresolvable by support!

TIA :slight_smile:

You may have to ask yourself as I just submitted the bug report about the installer.

You can uninstall whatever is there in your Apps listings then simply delete the other folders that you used for the same apps before doing a reinstall. It wont affect your registry.

Hi Don @AiDon

I just thought I had better update this thread.

So far support have yet to resolve the crashing with Face Refinement turned on…but I wonder how many others are still seeing this behaviour or is it unique to my system?

I am still in comms with support and will see what & how this might be sorted out.

FWIW as I do hardly portrait photography and the limited number of family photos I have taken in the past have never needed a size increase, Face Refinement is of little to no interest for me. So as long as Gigapixel behaves and works well on the sort of images I need to resize then all is well for me :smile:

I usually have face refinement turned on and have not had any crash issue. I’m running a Windows 10 machine with a Radeon RX580 GPU.


OK for clarity (DxO support are aware) I am using the nVidia GTX1050Ti