GigaPixel PS Plugin Not Opening from File > Automate

  • Using GAI 5.1.6 on Win 10 Pro PC (AMD Radeon processor - see snip below).


  • Want to use as plugin to Ps CC 2020. But can’t.

  • From File > Automate > GAI — program attempts to launch & fails. GAI splash screen with fox comes up then immediately closes and returns this msg (see snip) to Ps CC interface.

  • I’ve done all the usual stuff: (1) Re-started PC, (2) Launched GAI standalone b4 running plugin. (3) Tried different images. (4) Tried both max AI quality Yes & No. No luck.


  • Other 3rd party Automate plugins launch fine from my setup…

  • Previous commercial versions of GAI launched & allowed save back to Ps CC.

UPDATE: I just rolled back to 5.1.5 PR as a sanity check. It launches, processes & saves back to Ps CC layer. Something needs a fix in 5.1.6

Please provide the details of the image you are trying to process. Especially the color profile details including the bit depth (8/16/32), along with the color mode and color profile.

If the profile is “untagged” allocate the correct color profile before passing the image to GigaPixel.

Image size & details per Don’s request above for one tested image. As noted in my Update above, this image launches, processes, saves back to Ps using GAI vers. 5.1.5. It (and other images) don’t work as Automate plugin to Ps CC in vers. 5.1.6.

Color representation says “uncalibrated” so you will need to assign a color space before processing. It’s under Edit-> Assign color profile.

1 Like

Does this answer your question about image mode & color…

No the previous did as it is uncalibrated. That just says RGB/8. I suggest assign sRGB or AdobeRGB but check that it suits the image.

Okay. I’ll try that. I typically set all my processing to Adobe RGB 1998 for consistency.

OMG. Hope I don’t have to convert or assign every old image I’d want to use in GAI. That would be pretty overwhelming!

I’ll do the assign you recommend then will re-upgrade to 5.1.6 (since I rolled back to 5.1.5 to have working ops) to see if that does it. Fingers crossed.

p.s. Thx for the tips!

Here’s the story…

  • I did the Edit > Assign Profile on the closeup accordion image. Re-installed GAI 5.1.6 and it launched/processed as a Ps Automate plugin.

  • Then I tried another image from the same image set w/out the Assign Profile step & it launched/processed okay too. No need to do the Assign Profile step. Snip attached (Great Morgani - he was a reputable stock broker in NYC back when but either when he retired or he just decided that wasn’t his life passion, he got into street & event accordion playing & making funky costumes for himself).

But, gee, why did the closeup accordion image open just fine (with no profile noodling) in 5.1.5 and not 5.1.6?

I color code frequently used & semi-frequently used funcs in Ps menus. Now I’ve added Assign Profile to my semi-freq (or, semi-freak!) colored options just in case.

1 Like