Gigapixel Photoshop plugin results in same size image as original

I have an image in Photoshop that I want to resize in Gigapixel.

In PS I run Automate->Topaz Gigapixel AI

This opens the image in Gigapixel. I then press Save. (I’ve also tried Accept in the File menu).

This runs the AI upscaling in GP and puts the image back in Photoshop in a new layer (“gigapixel-layer”) but the new image is the same exact size as the original image!

I can tell that the plugin ran because the new image has the smoothing and sharpening applied, but the image is the same size as the original.

The only thing I can think of is that I’m doing this on a layer (with other images in other layers) and that the resize I’m requesting will exceed the current canvas. But I want this behavior. I’ll manually resize it down later if it’s beyond my current canvas.

Is the Photoshop plugin limiting the resize operation to the current canvas size? And if so, can that be disabled? Users should decide this behavior, if that’s what’s causing the issue.

Any ideas on what’s happening?

So, I realized what’s happening. The resize plugin does work it just resizes all layers at the same time, not just the one that I have selected.

Is this the desired behavior? How can one resize only the current layer with the plugin?

In other words, I have a bunch of images in separate layers. I copy a new image onto a new layer that’s smaller than all the rest. How can I resize just that layer with the plugin?


I think you’d need to send that layer to Gigapixel and resize it to be the same as the other layers (or the size of the biggest layer), but I haven’t tried it. As you’ve noticed, if you make that layer bigger than the others then they’ll all be increased to match the size of your layer enlarged in Gigapixel.