Gigapixel AI v4.7 crashes on launch on Windows 10

Tested on Windows 10 and Windows Server 2019.

Ran Windows Server 2019 on AWS EC2, and Windows 10 on Azure.

Error is exception_access_violation.

I’m using cloud based virtual machines because I only have a laptop and it’s very slow for my workloads.

You need to raise a support request at the main website on this issue to see if your setup is supported.

Alright, thanks for the heads up. What is this forum category for then?

Well this is a user to user forum and you have an unusual environment that is not mentioned in the technical requirements as supported.

In my experience virtual machines have issues with GPUs as the drivers are not the same as is available for windows.

Also as all the AI products have extensive hooks into the hardware there may well be a effect because of the windows version, vGPUs and vCPUs that only support could answer unless a user on this forum has had experience.

Oh okay, I understand the user to user idea now.

I debugged the issue. QT resolves OpenGL bindings at runtime and it was calling glBindFrameBuffer when the VM driver didn’t support it for some reason, so it was jumping to a null pointer. Weird they don’t check for that and issue an alert or exception.

Fixed it by installing the correct NVIDIA driver. Unfortunately even with a Tesla GPU the application doesn’t run very fast. I don’t think it’s been profiled very well because CPU & GPU spike briefly but then have long valleys of inactivity.

Basically Telsa GPUs have modified drivers and therefore may not have the vanilla NVIDIA drivers.

VMs have huge issues. Even if you get working drivers, it still can fail on all sorts of applications. Just try one thing: Disable GPU accelleration and test, if the CPU at least ramps to 100%. It absolutely should. If not, there might be other driver issues. I even had some problems inside VMs with HDD drivers (yeah, there seems to be some emulation of some sorts in some circumstances). The HDD only ramped up to 2mb/s for large files. Absolutely unusable. It should not matter that much for Gigapixel AI.

Just try CPU only and report, if the usage of CPU ramps up more.

Edit: I know it is verry unlikely, but could it be, that the problem comes from no attached monitor? I even ran into issues with no monitor connected to the GPU (not in Gigapixel, but worth investigation, since it seems GPU related). Also look at harddrive usage. Benchmark of HDD would be also a good idea, to figure out, if there are performance issues. A RAM benchmark also can tell you, if the RAM performs as expected.

All extremely unlikely, but definitely possible. (Compatibility mode tested? Just fall back to Windows 8 or 8.1 for example. Would be just a workaround, if it works - but better than nothing)

Did anyone fine out if AWS instances are supported with Topaz Labs or have a recommended instance type and AMI that we could use?

I would like to just spool up a high performance cloud server and pay by the drink than spend 2k on a new power drain?

It ran really badly on AWS for me. It works much better on Shadow.

Thanks for the reference to Shadow. Hadn’t heard of that service before but looks like they are pretty booked up. I couldn’t get a machine until July 29th.

I was able to get it running in a VM on AWS fairly well. I have an old Macbook Pro from 2013 so Enhance AI will only run a few seconds of a video upscale before it crashes. For the per frame it was around 7 sec/frame before it crashes so I have something to compare against.

I used:
g4dn.xlarge instance (4 Xeon Cores @2.5GHz, 16GB RAM, and Nvidia T4 16GB) with a Windows Server 2019 AMI. The ID is below:

Using the above video for comparison I was able to get about 0.15sec/frame.

Cost about .75cents to run that instance per hour at the On demand rate. It is about half that at the spot rate on AWS.

Thanks for the stats. I can’t remember how many seconds per frame I was getting since it’s been about a year now since I ran it. I didn’t feel it was very cost-effective.

I’m getting 0.64-75 sec/frame on Shadow Ultra @ $30 a month, with 8 core Xenon @ 3.3GHZ, 16GB RAM, Quadro RTX 5000, Windows 10.

I don’t know how truthful Task Manager is, but I’m only seeing 14-15% utilization of the GPU. 14% of video encode, all other metrics very minimal. 2.5 GB / 16GB dedicated GPU memory. CPU hovers around 50% for a while, then spikes up to 100% briefly.