Gigapixel AI v4.0.0 very slow

My previous version 3.x.x Gigapixel AI ran just fine.
Windows 10, 64bit, 16GB RAM, NVIDIA GTX 1050 Ti with 4GB.
The ‘new’ version is so slow! Slow as a wet week (and that is really slow).
Tried images that previous version just blitzed through, and the new version is so slow that I now just minimize the window and do other things until it finally finishes.
Have not bothered to see if I also have the same problems as others have (EXIF removed, etc) as I don’t think I really want to keep using this new version.
Can I roll back to the trusted older version?
Yes…I have the GPU ‘ticked’ to use.
CPU is Intel i5-3470 @ 3.2 GHZ.

Please go to Help-> Graphics info, press the Copy button and paste the information in this thread.

Application & Version: Topaz Gigapixel AI Version 4.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 1050 Ti/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 418.91
CPU RAM: 16315 MB
Video RAM: 4096 MB Total, 3388 MB In Use
Preview Limit: 5967 Pixels

Under File / Preferences you can set use max quality AI models to No and see if it runs better for you.

Waste of time. It runs slightly faster…but why do I have to nobble the software to speed it up?
The old version would rocket through a 6x bigger image while the new version is only set on 2x image size and still it crawls along.
Where can I download the older version 3.x.x from please as the version 4 is certainly not ‘match ready’.

Just in case…I uninstalled the version 4 AI Gigapixel, downloaded and installed a new version of it…and it’s still the same.
I only did that because I’m sure someone would suggest that as a fix.
Version 4 is no good at all. I seriously want the older version back please. It worked perfectly until Topaz ‘fixed’ it.
Can I have a link to an older version download please?

Just raise a support request to see if there is a installer available.

Stay with the old version … AI is a completely new environment, and I think that the diversity of response from “standard hardware” i.e. 16Gb, 4Gb VRAM, i5+ (or whatever’s the same for Mac users) has even surprised the developers. I admire Topazlabs bravery in venturing into this new arena, and it is ‘finding-out’ our hardware. I recommend patience as Topaz labor towards resolution. They are a small company coming to terms with huge change!

2 Likes

Can you define what slow is? The picture size and time to process to a jpg. thanks

I just ran a test and it seems slower on my machine as well but a 2815 x 1877 px file X3 set to med low noise reduce and medium reduce blur took 1 min and 13 sec. using a Radeon RX580 card.

OK…in the last of the version 3 (3.1.1 wasn’t it?) I could run the ‘scale’ at a custom setting of 9. This gave a huge file (+150MB if I recall correctly).
The conversion took about a minute. I was most impressed. A 6x enlargement was even quicker. Less than a minute.
With version 4 I just have to minimize the program and do other work while the program bumbles around getting sorted.
5 minutes and counting for a 2x enlargement (6000 x 4000 original image) is NOT an improvement Topaz.
This version 4 sucks badly.
I have raised a support ticket and asked for a link back to the older version.
Is my graphics card the problem? A GTX 1050Ti, 4GB should be OK and worked well with version 3 of the software.
To upgrade to a card with 8GB is over $700 in New Zealand. Will I do that? Hell no. I’ll dump my Topaz products instead.
If Topaz can’t ‘fix’ this I will certainly be looking for a refund as version 4 has stuffed up what was a great program.

The original AI Gigapixel was much slower than V4 and Topaz found ways to speed it up and I think they will on this as well. This version has a lot of improvements. You might hold off getting a refund and see if they increase the speed.

This latest version of AI Gigapixel is unusable for my production work. That is the case for one reason; it is way, way, way too slow. The earlier versions worked much faster for me. I know of nothing out there that can compete with the quality of the final results of AI Gigapixel. However, there is resizing software that does a good enough job and is way faster. I hope that Topaz is not really satisfied with this product.

2 Likes

Thanks Jack, I was sure it wasn’t me or my computer that was the problem.
The worst part is that even if I spend the $700 or so to get an 8GB graphics card that the AI Gigapixel will still be slow.
I do wonder how Topaz developers test these things.
What equipment do they use for their testing/everyday use?
Surely can’t be plain old vanilla flavour computers as lots of folks are going off pop now about the version 4 ‘update’.

My testing is as follows (default settings for 4X upsizing):

Gigapixel AI version 3 (last): 3m33s on 1 GB Radeon HD7770 video card -> 53 s on new 6 GB GeForce 1060
Gigapixel AI version 4 (newest update yesterday): From 53s -> 1m58s on Max Quality or 1m09s on NO max quality

So the latest update has basically halved the overall processing speed as far as I can tell (assuming Max Quality on by default in V3 or whatever last was before the update yesterday).

Application & Version: Topaz Gigapixel AI Version 4.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 1060 6GB/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 419.35
CPU RAM: 16336 MB
Video RAM: 6144 MB Total, 5660 MB In Use
Preview Limit: 7917 Pixels

Not sure I’m reading this right…you went from 53sec with the later card (GeForce 1060) and version 3 software.
Now with same graphics card and version 4 you are at 1m 58sec? Or…near enough to 2 minutes anyway.
That’s a doubling of the time to do the same job (twice as long compared to older version 3 software).
Is that right?
You are so lucky if it’s only twice as long. Mine is 5x longer to do the same images.

Yes 53s -> 1m58s on the same image 4X scaling default settings with all computer hardware the same (Geforce GTX 1060)

Ah, OK…then yes, your computer now takes slightly longer than twice as much time to do the same job as before.

I’m experiencing the same type of slowdowns with a GTX1050/4GB plus there are issue with the lastest drivers from NVIDIA

My good times and bad times were all on the same version NVidia drivers - only difference is Gpxl AI v3 versus Gpxl AI v4.

I personally haven’t found any issues with the latest NVidia drivers but maybe I’m not looking hard enough as everything has run stable with no crashes or lock ups.

I’ve tried 2 different NVIDIA drivers, but not using the latest one (419.) as have read on this forum about problems.
Saying that though, it should be noted that I had absolutely no troubles with the AI Gigapixel version 3 on my computer.
When the version 4 went so slow I ‘updated’ from a 417. driver to a 418. driver in case that helped. Sadly it didn’t.

In reply to ‘Artisan-West’…I resized an image down to the size you gave (2185 x 1877), ran the software at 3x as per your setup, and did it in 1m38seconds.
That is quite slow for my computer compared to version 3 AI Gpxl.