Gigapixel AI only upscales for me

Hello, I’m new to Topaz Labs, and today I started my trial for Gigapixel AI. I noticed that whatever settings I enter into the program, I always get the same result, which is just an upscaled version of the original image with no corrections made. This happens for any image.

My friend and I did a comparison test by using the same settings on the same image.
Here’s the results:

Would anyone know why this is happening? My computer meets the requirements, and I even did a reinstall, so I’m not sure what else to do.

Firstly go to the Help menu, click on Graphics info. then press Copy and paste the results here.

After that open the Preferences under the File menu and click on calibrate, open an image and allow the application to calibrate its optimal process combination of GPU & OpenVINO.

For that image choose the Art model & Auto to start with.

Application & Version: Topaz Gigapixel AI Version 5.4.1
Operating System: Windows 10 Version 2004
Graphics Hardware: GeForce GTX 970M/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 457.30
CPU RAM: 32717 MB
Video RAM: 3072 MB
Preview Limit: 3981 Pixels

I also did the calibration, and tried with the Art model with Auto enabled, but same result.

Your NVIDIA driver is a little out of date, so get the latest from their website.

Are you using the app as a standalone or as a plugin? If as a plugin what is the host?

Good call, I’ll update the driver now. I use the app as a standalone.
Also, not sure if it’s worth mentioning, but I just started using Video Enhance AI as well and I haven’t had any issues with that whatsoever.

1 Like

Hey sorry, I forgot to report back. So I updated my drivers and recalibrated the app again, but still no luck.

My suggestion is you raise a support request at the main website.