GigaPixel AI CRASHES all the time

GigaPixel AI:

In that past, like in 2019 and 2020, this product worked perfectly and then sometime in 2021 it started crashing on me every time I used it and still does to this day.

Then recently there was the release of Photo AI and the first few times I used it to enlarge photos, it worked fine but then the it started to produce artifacts in my images - especially noticeable in sky areas.

I have the most recent version of Photo AI 1.0.10 installed and I am running all this on a Mac Mini:
Screen Shot 2022-11-30 at 1.30.13 PM

Am I the only one experiencing these issues?

Based on that type of behavior, I would strongly suspect it is lack of sufficient HW resources, most likely graphics VRAM. As the app’s appetite grew (size of apps, size of AI models, etc) your HW became insufficient. The application should die gracefully in that scenario with an informative message, but sometimes that is not the case (due to inadequate coding).

Unless I’m mistaken, your graphics VRAM of 1.5GB does not meet the minimum stated
here which is 2GB. If you want to confirm for sure you might open a support ticket and they may ask you to provide a crash dump to confirm. Or they may just say “not enough VRAM”.

PS You might check your Prefs settings and make a change to the Allocated Memory Consumption and see if that helps.

HTH.

Thank you very much for your response. I figured it was something along these lines but had to ask.

Hmm, just purchased this and 3 times out of 3 it’s crashed whenever I try to apply changes.

I’m on a brand new M1 Mac.

I don’t use GPXL, but assuming it is like the other apps, you’ll want to…

~Help->File-logging->[On]
~Run the app (presumably crashes & generates a trace dump)
~Open support ticket (inform them that you have a crash dump to upload)
~Wait for analysis from developers