Gigapixel AI 5.1.6 - Photoshop Plugin crash

I’m trying to open a photo into Gigapixel AI 5.1.6 using the photoshop plugin. Gigapixel AI opens and crashes when it attempts to load the photo from Photoshop. The photo is ~1200x1250.

Hardware specs are i7-9700k, GTX 1070ti, 32 GB RAM. Win10 64-bit

UPDATE: The photo I was trying to upscale was a copy-paste off of the internet into a project in photoshop. I tried opening *.dng from a photo I had taken. The raw file opened without issue, but the copy-pasted photo results in a crash. I am attaching the offending project. I’ve tried a couple of different photos that were copy-pasted into photoshop the same way and all of them caused Gigapixel AI to crash. It’s worth noting that this issue began today after updating to 5.1.6. (remove the .txt file extension on Untitled-2.psd.txt to use it)

2020-09-11-09-30-16-QML - Copy.tzlog.txt (5.4 KB) 2020-09-11-09-30-16-Main - Copy.tzlog.txt (70.9 KB)

Untitled-2.psd.txt (761.9 KB)

I am having same issue, photoshop loads up gigapixel then it crashes. Software works standalone and also in lightroom classic. tried uninstalling plugins and reinstalling with no success.