Gigapixel AI 4.1.0 adds awful gritty texture to images when using CPU :(

So I’ve just updated Gigapixel AI from version 4.0.2 to the latest 4.1.0 version, thinking it will be a worthwhile thing to do. Unfortunately, I soon realized it was a mistake - I noticed that all my upscaled images have started getting awful gritty artifacts/texture similar to rough canvas paper. Even with “Suppress Noise” set to “Medium Low” and with images that are noise free. This is most visible in areas without a lot of detail and contrast. “Keep Color Profile” set to “Yes” exacerbates this problem but even if I chose to convert the colors to sRGB (which adds another problem - color fringing), the gritty texture is still visible.

I upscale my images with CPU and “Use maximum quality AI models” enabled. I use these settings 99% of the time even though it’s slower than GPU because it’s been giving me superior results compared to using GPU. I don’t even want to use GPU because it’s producing horizontal banding artifacts and the images are generally more blurry. At least in this latest version. So this is not an option/alternative. :frowning_face:

Anyone else noticed this issue? How can I downgrade to the older version - Gigapixel AI 4.0.2? On the download page there’s only a web installer which downloads the latest version which I don’t want. I want to revert back to Gigapixel AI 4.0.2. :frowning_face:

My hardware setup:
CPU: AMD Threadripper 1950x
RAM: G.Skill 32 GB DDR4 3200 Mhz
GPU: GeForce GTX 1080 Ti 11GB Founder’s Edition

They’ve updated to 4.1.1 as of this morning. Has that helped?

Sadly not. I’ve just tried it. Right now I just want to revert back to 4.0.2 as 4.1.0 and 4.1.1 are almost unusable for me in this state. :frowning_face: I really don’t like this gritty canvas texture that makes everything look rough, especially areas that are flatter and don’t have a lot of detail. It’s most noticeable on skin/faces which makes them ugly looking. :frowning_face: Really bad. The only way to make it disappear is to use a Noise Suppresion level of Medium and higher which strip out lots of detail in the images. I never had to go Medium or higher in 4.0.2 so detail was very well preserved with no ugly gritty canvas-like texture. The older algorithm was way better. :frowning_face: Again, I’m only talking about CPU + “Use Maximum Quality AI models” here since I almost never use GPU due to the inferior results (blurrier image, horizontal bands and lines over smooth areas) even though it’s faster.

I had assumed that both the GPU and CPU modes would use the same AI process, and thus produce the same output files, with the only downside of using the CPU being a much longer process time.

It appears that assumption may be wrong. The output images not only look different, but the files sizes are significantly different.

Perhaps CPU mode uses a different process altogether.

@svetlina_design I use the GPU but turning off the “Use Max Quality” option in the preferences will cut the time in half and produce better results. You can try it for both CPU and GPU to see which give better results for you.

I have the same issue with Gigapixel A I as well as Sharpen A I. Strong banding is visible when I set both apps to use a dedicated GPU (in my case it’s Nvidia GeForce MX 940; I’m working on a laptop). Both apps are up to date. In the case of Sharpen A I, banding appears when I use the Stabilize function.

On my system (i7-7700K & GTX980) I can minimize the banding and optimize processing speed in Gigapixel AI by using:
Max Quality AI = No
Enable GPU = Yes
Memory = Medium
OpenVINO = Yes