Gigapixel 7, upgrade, Intel MacOS, and incredible, hardcore OS crashes

So…

Received the “Upgrade to 7!”, so took the plunge, installed it, but then (boom)…

The app will crash so spectacularly hard, it is worse than the time I inserted the wrong RAM chip.

How it comes about: So after tweaking, it shows results, but after clicking “Photoshop”, the little circle will start to spin (prefer the straight one, but, eh), them freeze…

(fade to black)

…Then I’m back on the login window, but it will stay there until you punch the restart button on the (Intel ) iMac.

*Tried all 8 AIi modes (boom)

  • Sizes (boom)
  • Settings (boom)
  • By percentage, width, height (boom)
  • Faces (boom)
  • Gamma (boom)
  • (also waiting on the result, then try to save, or immediately clicking/save to Photoshop) boom

Aaand…

  • Reinstall/install (boom… yes all this was tried; it’s a valuable PS Plugin tool, is needed)
  • Reinstall/install ALL Topaz apps back to the iMac (boom)

Tada! Hoping for a quick update release of Gigiapixel 7 (1.x/2/x)

Cheers

Well, this doesn’t sound great at all.

Does your machine meet our system requirements for Gigapixel? I suspect it would only be crashing like this if that was the case.