Gigapixel 6.3.3 hangs w/ RTX3070 50% of the time

Steps to reproduce issue:

Gigapixel 6.3.3 i9-13900KS 64GB DDR5 RTX3070 Win11pro 10.0.22621 Build 22621

Try loading a variety of different pictures at different sizes and different noise levels.
“Standard” setting, Height=1080
Progress bar gets halfway across and program freezes.
This only happens with about 50% of the images I tried.

NEVER had this problem with my other 1050Ti machine.

Win Log just said: AppHangB1

Then turned mode setting from auto to CPU and everything worked, though when the progress bar got half way it paused for 2-3 seconds then the cpu fans went into overdrive mode, but it worked.

All my other Topaz programs seem to work.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Go to Help-> Graphics info., press Copy and paste the info here.

When I follow the link to your reply I don’t see any “Help”.

During log:

After log:

So, after much testing here’s my conclusion: the failed images probably all had some jpeg implementation flaw AND contained an image of a face. The progress bar getting half way is the dividing line between the non-face processing and the face processing. This doesn’t explain why the 1050Ti and the CPU implementations succeeds where the 3070 fails.

Open the application and you will see the help menu.

Application & Version: Topaz Gigapixel AI Version 6.3.3

Operating System: Windows 11 Version 2009

Graphics Hardware: NVIDIA GeForce RTX 3070/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 528.49

CPU RAM: 65243 MB

Video RAM: 8192 MB

Preview Limit: 8000 Pixels

I suggest raise a support request at the main website as I have 2 PCs, one with RTX3060 and the other with GTX1050, and I don’t experience the problems you are seeing. The only difference is I use Win 11.

I am also using 11 on my new machine but 10 on my older machine.