Gigapixel 4.45 slow

I’m having a problem with AI Gigapixel 4.45 being extremely slow to process. Today I tried to process a composite image using these Preferences:

It took about two hours to process the image. So, I changed the Preferences to the following:

Still after an hour the photo was not completely processed. You can see the time progression in the lower right hand corner of the screen shots to see how long it took to get to 55 minutes and it still was not complete.

Does anyone have any suggestions to speed this up?

Here’s my Graphics Info:
Application & Version: Topaz Studio 2 Version 2.2.0

Operating System: Windows 10 (10.0)

Graphics Hardware: Intel® HD Graphics 520

OpenGL Driver: 3.3.0 - Build 21.20.16.4550

CPU RAM: 12152 MB

Video RAM: 1500 MB Total, 1200 MB In Use

Preview Limit: 3466 Pixels

I would expect that if you are using the integrated graphics HD Graphics 520 as it only has 120MB of dedicated vRAM. If you have an alternate high performance GPU use that, it can be allocated in the Settings panel using Graphics Settings

If not, press reset in the Advanced Preferences after setting graphics memory consumption to medium and if your CPU is modern enough it will select OpenVINO as the processing option.

@fotoman You have a very under powered GPU. Make sure other programs are not running when you use Gigapixel. Just as a comparison I cropped a pictured to 5342 x 4246 (close to yours) and ran Gigapixel at X2 to see the time. Mine took 2 minutes and 56 seconds to enlarge including file saving time with Max quality.
Update: I ran the picture through Denoise AI and retested. In max quality mode (GPU) it dropped to 2 :43 and with Max Q off it was 1:35. I could see no difference in the two pictures

If you are using a desktop/tower computer you should upgrade the video card.

Thanks Artisan. I’ll try that. Unfortunately, I have no way of upgrading my graphics card. Didn’t have this problem until recently.

Don: Will do. I’ll let you know what happens.

1 Like

Didn’t work well Don. Slooooooooooow!

Harry

Harry, if you are using Windows, look at the task manager to see if something is using a lot of CPU time in the background. Since you said it use to be much faster, maybe you have a virus or some program that is using a lot of processing. If you find something, end the process and retry Gigapixel.
Ron

I have a fast machine iMac Pro with a Radeon 64 GPU. Gigapixel version 4.4.5 runs okay for 10-20 images then starts becoming unresponsive, eventually so bad the beach ball just sits and spins. The only solution so far has been to reinstall the program, and then it runs fine for awhile before choking again.
I have 64GB of RAM, so it is not hardware limitation. Running MacOs 10.13.6 Seems like a software issue. Fixing permissions, clearing memory does not help.