Fusion Express & Mac OSX Sierra

Hi all,
I have installed Mac OS Sierra on Mac BookPro. It seems that Fusion Express, to be installed the Topaz products as Lightroom plugins, is not compatible with OS Sierra. So, how to use the products as Lightroom plugins?
Thanks
Roberto

Have you downloaded and reinstalled Fusion Express?

Yes, I downloaded and installed the last version available on the web.

We have a guide for setup in Lightroom here:

Yes. I have downloaded and installed the last version available on the web.

Are you running Beta software? That is macOS Sierra 10.12.6?

Because if you are it isn’t supported.

I’m using the last release of Sierra.
In this case, if Fusion isn’t supported how to use the plugins with
Lightroom?
Regards
Roberto

What is the release number you are using?

The release number is 10.12.6

OK … that means that the Beta was officially released and seemed to be on July 19, 2017 (10.12.6 (16G29) )

You will need to raise a Technical Support Request at the link above at the “Submit a Ticket” link next to the “Topaz Plugins Help Center” as it seems something has changed.

Ok. I open a new ticket at Help Center.
Thanks
Roberto Pagani

1 Like

Hi Don,
is there any solution to this issue ?
I just installed the topaz & fusion express packages , configured in lightroom 6 ( was already there, but checkd).

When i try to edit in Fusionexpress LR creates the tiff but then nothing happens.
I figured out, that the access rights of the “Topaz Fusion Express 2.app” are different to the other plugi-apps:

drwxr-xr-x   3 admin  staff  102  3 Dez 13:34 Topaz DeJPEG 4.app
but 
drwx---r-x   3 admin  staff  102  3 Dez 13:34 Topaz Fusion Express 2.app

Nevertheless , changing the accessrights with “chmod a+rx” doesn’t fixes it.
when starting the app from within finder, it says: can’t open because it’s probably damaged…

I have Sierra 10.12.6 running.
Other Topaz apps ( Adjust 5) work fine.
Regards
Stefan

Hi,

Are you saying that when you call DeJpg it doesn’t open or any application doesn’t open through Fusion Express?

One thing you can do is download the new Topaz Studio app and use that instead. Note the current versions are Adjust 5.1.0 and DeJPEG 4.0.1 and these must be installed.

Studio download: https://web.topazlabs.com/downloads/

Studio is the current preferred host and is free.

Hi Don,
thanks for the fast reply.
What i want to do is, using the topaz plugins whithin lightroom.
DeJPeg 4 works fine from photoFX lab. It was just an example regarding the different access rights.
What does not work is “Edit Foto in Fusion Express 2” from whithin Lightroom on my macbook pro.
On the instruction page http://www.topazlabs.com/application/installation-guide/mac-lightroom.html is stated, that Fusion Express 2" is needed…
Further on is stated, that while some plugins work directly as external editor, some others still need Fusion Express.
so i installed it and tried to reach topaz plugins.

Thus i cannot reach the Plugins which need them (esp. Clarity).
Of course any other solution reaching Clarity & Co from lightroom would be fine…
Just tried to add Clarity as external editor…the app crashes, saying:
"Cannot load library tlImageIO:
I found out, that “Edit in PhotoFXLab” allows me to use the plugins, although i have than to load the plugins individually which lengthens the workflow…

May be Fusion Express 2 is not needed anymore ?

I really advise you to use Topaz Studio rather than Fusion Express … all existing plugins are available through Topaz Studio so it is a one point call. Clarity has already been updated to be part of Studio and as a Clarity owner you are entitled to free upgrades.

Previous versions of Clarity, Detail, Impression and Simplify have already been migrated and upgraded to Topaz Studio. Note that you will no longer need Fusion Express and you will be able to reach all plugins from Studio.