Flickering while using freesync

I normally run Topaz on a 60hz monitor, but I discovered that when I run Gigapixel (or TPAI) on my gaming rig (120hz freesync monitor) the screen flickers / repeatedly changes brightness. This happens when moving the mouse within the app window or processing a photo. TVAI doesn’t seem to have the issue. Disabling freesync solves the issue, but I was wondering if there was something Topaz could do in an update that would fix the issue? Disabling freesync is just a few clicks, as is re-enabling it, but skipping those clicks altogether would be preferable.

Windows 10
5800X3D
4090

try enabling/disabling g-sync (in the nvidia settings), while leaving the freesync on your monitor activated.

That’s how I’m doing it now. Just a few clicks through the nvidia software, but I have to do it before and after running Topaz in order for my system to perform properly in games. Gigapixel and TPAI are the only two programs I have noticed to have this issue.

It’s not a huge deal, but not needing the before-and-after special attention would be better.

you could create an app profile within the nvidia settings (for all 3d apps like topaz ones) and turn off gsync for them.

1 Like

It’s been a while, but I thought the per-app drop down was seperate from the gsync / freesync section.

The section where I have the option to select a specific app and make a profile has a long list of settings…but I don’t think gsync is one of those options.

I will check later today.

the app specific settings include options to turn on/off vertical sync, and also the type of sync you want to use.

I switched the monitor technology setting to fixed refresh rage to turn off g-sync for this specific application but it still changes the brightness when I select or deselect the application window.

there is a distinct option for turning vertical synch (on/off/fast/default) for an app

Negative. This option does not exist. The available options are:

  • global settings / g-sync compatibility
  • g-sync compatibility
  • fixed refresh rate.

According to ChatGPT the last option would turn off g-sync.

grafik

I can turn off VSync there but not G-Sync.

yes, that’s what the setting is for… the g-sync technology can be turned on/off seperately

not in that menu. it is only about VSync, not about G-Sync!

It’s in there. There’s two different entries on the list. GSync /free sync is further up the list than Vsync.

I changed 3 settings. Can’t remember the third, but I managed to make things worse before I found the combo that worked. I’ll check it tomorrow and post up the settings.

All that being said, I wish Topaz could simply make this unnecessary in an update.

topaz has no control over how your gpu-driver/screen combination behaves.

No other programs on my PC have this issue.

Are you suggesting that every other program on my PC has this “control” and that’s why no other program on my PC requires this special attention?

1 Like

the problem is that some software utilises technology which “triggers” your gpu-drivers to turn into 3d mode, even when being on the desktop. and in that case, your gpu driver will start doing its thing and apply those 3d settings, among them vertical sync, free/gsync if so chosen, display frequency and all the other good stuff you see in the dropdown menu - which may work well in fullscreen and with certain hardware combinations (not all) but may as well have its flaws when being applied under desktop conditions. the quick flickering brightness changes you described are typical for a sub-par gsync operation.

if the gpu driver allows for it, topaz could tell it to apply certain settings (the ones which you can already manually set up in the nvidia settings menu for specific apps) but why would it try to override potential changes you want to have set up in your nvidia settings? no need to. just create a profile and it will work.

It looks like the per-program screen shows defaults when I check, rather than the custom settings that I chose (and it’s still actually using the custom settings because it’s still working properly) …so I will just try to note the settings I changed:

“Monitor Technology” should be “Fixed Refresh”

“Vertical Sync” should be “on”

I think I also chose a “preferred refresh rate too”, but I’m not sure. Again, the driver seems to be showing defaults rather than what I changed.