Fatal Error on Gigapixel 7.0.0 install

My current installed version of Gigapixel is 6.3.3 and I am able to open it. When trying to upgrade to Gigapixel 7.0.0 from within Gigapixel, I received a message that the version 6.1.0 uninstaller was not found and then received a “Setup Failed” error message (Ox80070643- Fatal error during installation). Gigapixel does not show up in the list of “Add or Remove Programs” list in Windows. I have tried the upgrade process several times with the same result. I am running Windows 11 with all latest updates.

1 Like

I am having the same issue and am also on Windows 11. I sent a message to support as well as checking on this forum

I am having the same issue.

I can get it to install but it will not launch. On Windows 11, all up to date. No error messages, just will not launch.

Got it working now. Had to rip out the previous version completely and run a registry scan to remove any debris. Did a clean install and it now launches.

What @georgemon said is correct.

This is a known conflict that we’re investigating.

If you’re getting this, you’ll need to completely delete the installed Gigapixel and it’s registries and then reinstall Gigapixel 7 from our Topaz Labs Download Page.

We’ve only seen this conflict occur on Windows, so open program Registry Editor from your Start menu explorer and delete the registry entries of Topaz Gigapixel AI, if there are still any, in:

Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Gigapixel AI
Computer\HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI

1 Like

I uninstalled Gigapixel 7 and removed the registries, restarted the machine and reinstalled Gigapixel. It wouldn’t start. I uninstalled everything, made sure all registry keys were deleted, reinstalled and tried again. Gigapixel still wouldn’t start. After thinking about for a while, I uninstalled Gigapixel 7, went to the Programs folder and noted the Gigapixel Folder was still there and populated with files. I renamed that folder (just in case) and reinstalled Gigapixel and, voila, that worked. I checked Lightroom and it was also able to open Gigapixel, so I think that is solved.

I used this approach and it launched. There is something in the Progrtam Files\Topas gigapixel folder that stops the launch as i had unistalled twice before without this step without success.

1 Like