Fatal Error during installation

I’ve using Topaz Photo AI for a couple of days, but then I got the following error:
‘com.topazlabsllc.photoplugin’ is not a valid short file name.
Followed by Fatal error during installation.
I thought I’d try to uninstall and reinstall, but the same error occurs when attempt to uninstall.
Then I physically deleted the Installation and tried reinstalling but same error.

Follow-up regarding the com.topazlabsllc.photoplugin’ error.
After examining the Registry, I noted that the com.etc was referenced to a directory on a Bitlocker USB drive: x:\COne\Plugins\com.topazlabsllc.photoplugin.…
Once the folder was available the reinstall and program work.
So why did that plugin end up on a USB drive?
There is a directory in the installation folder by the same name, but when I remove the directory from the USB it simply replaces it.
When I physically removed the USB and ran Topaz Photo AI the program configures itself and creates the COne directory elsewhere. This time it’s put it on a Back-up drive, which is ok for now, because its always attached and is not a BitLocker, but it does seem a bit peculiar that the installation picks a random drive to save the plugin to.

To resolve fatal error during software installation, follow the steps given below:
Remove files of earlier installations.
Ensure the user account has administrative privileges to install software.
Resolve machine-specific issues.
Resolve Common Windows Installer issues.
Make sure to kill the related processes.

Rachel Gomez

Have the same issue getting the ‘com.topazlabsllc.photoplugin’ error trying to update. I can use the programs, i just can’t ever update it. So, i’m locked in at Version 1.0.1… wonderful…