"Error writing image"

When processing batch images from Lightroom, upon saving back to Lightroom, many images fail to save back to lightroom and display “Error writing image” dialogue, and then proceed to the next image. This occurs at a rate of about 30-40% of images in queue.

Steps to reproduce issue:

  1. ‘Edit in Topaz AI’ option from Lightroom Classic (using adjustments)
  2. Make adjustments in Topaz AI
  3. Save images back to Lightroom Classic
  4. Watch as 1 out of 3 images fail to save

Topaz Photo AI 1.4.3 on Mac

Please open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option. Attach the logs files that you can see in the window that opens.

I am having the same issue. M2 Max Maxbook Pro 64GB of RAM. OS Ventura. I have attached the log files.
2023-08-08-12-47-25.tzlog (2.9 MB)
2023-08-08-13-08-38.tzlog (3.1 MB)

2023-08-08-13-38-41.tzlog (42.4 KB)
2023-08-08-15-14-1.tzlog (101.5 KB)

2023-08-08-15-17-35.tzlog (1.1 MB)
2023-08-08-15-37-51.tzlog (183.9 KB)

2023-08-08-15-39-5.tzlog (200.2 KB)
2023-08-08-15-43-50.tzlog (1.6 MB)

Thanks for sending the files over. It looks like the processing failed.

Please open Topaz Photo AI and go to the Topaz Photo AI > Preferences > General > AI Processor menu. In the dropdown menu, select Apple M2.

Try processing an image like that and let me know what happens.

2023-08-10-17-20-24.tzlog (1.6 MB)
2023-08-10-17-23-46.tzlog (4.6 MB)
2023-08-10-17-18-36.tzlog (16.5 KB)
2023-08-10-16-36-33.tzlog (227.3 KB)

It looks like you are using an unsupported file type.

From the Supported Cameras article, unsupported files include:
Sony: Lossless Compression Medium and Small (Large, Uncompressed, and Lossy Compressed RAW are supported)

If you want to process these files in Topaz Photo AI, I would recommend converting to DNG or a non-Raw format before sending it to Topaz Photo AI.

Let me know if that helps.

Thanks for the info. I wish I had known that beforehand. Will these file types be supported any time soon?

We have reached out to Sony but haven’t heard back with instructions on how to support these files.

At the moment I don’t have a timeline on when we could support this.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.