Error saving after using Topaz in Apple Photos

Using Apple Photos to edit pictures using Topaz 2.3.0. Image processes but when you click on Save Changes get an error message as show in screenshot. Rebooted computer and checked for updates but still won’t save changes. Was working fine this morning then just started this error. Tried multiple different pictures

Steps to reproduce issue:

  1. Open a picture in Apple Photos
  2. Edit>select Edit using Topaz
  3. Process the picture, Then click Save to Apple Photos. After processing press Save Changes. Error message then appear.

Topaz Photo AI [2.3.0] on [Mac Sonoma 14.2.1
2024-01-27-11-45-2.tzlog (127.7 KB)

Please send in your logs

open Topaz Photo AI and go to the Help > Open Log Folder menu option and Email me all the logs files in the folder.

Also try editing the image in the standalone Topaz Photo AI app, and see if you have the same issue saving. This will allow us to narrow the cause of the issue

Thanks

It cleared itself up the next day.

2024-01-27-11-53-12.tzlog (128 KB)

2024-01-27-11-54-8.tzlog (34.1 KB)

2024-01-27-11-54-35.tzlog (128 KB)

2024-01-27-11-57-28.tzlog (127 KB)

2024-01-27-11-58-10.tzlog (33 KB)

2024-01-27-12-01-9.tzlog (123 KB)

2024-01-27-12-02-11.tzlog (252 KB)

2024-01-27-12-21-25.tzlog (140 KB)

2024-01-27-12-24-5.tzlog (105 KB)

2024-01-27-12-26-13.tzlog (146 KB)

2024-01-31-16-09-27.tzlog (30.5 KB)

lastSessionFiles.txt (207 Bytes)

1 Like

I don’t think so. The problem is known and now really loooong standing - it just only appears with portrait oriented photos, not landscape ones and also only on photos that you didn’t edit before in Apple Photos. So you might mistakenly got the impression that the issue was solved…

Try again with an previously unedited photo that was taken in portrait orientation.

See also here:

This topic was automatically closed after 60 days. New replies are no longer allowed.