Error Message - Missing/corrupted model file

Yesterday I upgraded to the latest Sharpen AI version by buying a year of upgrades (my existing version was very, very old). When I installed Sharpen AI everything went well, but the second time I called the app from an external editor (I use PhotoLine) I got an error message telling me that there was a processing error and the auto settings model file was missing or corrupted (see screen shot below).

So I uninstalled and reinstalled Sharpen AI and the problem disappeared when I called it from PhotoLine, but reappeared the second time it was called, exactly as before. So I again uninstalled and reinstalled Sharpen AI and agin, first time it worked, second time it gave me an error. Has anyone seen this error? Or know how to prevent it?

Sharpen AI still works, but the 4 image comparison showing each of the models and how they compare does not work. I am going to do some research to see if I can find out what model file is the problem but this is really frustrating. I will file a bug report but does anyone know how to avoid this problem?

To be absolutely clear: This problem exists when I call the Sharpen AI app from an external editor. It does not happen (yet) when I use the plugin.


I am getting this symtom too, in my case when I call Sharpen AI from DXO Photo Labs.

It first happened when I installed a single update earlier today.

I’ve since unistalled Sharpen AI, and downloaded and installed the full version. The problem persists!!

And the problem is not what the error message says it is.

I uninstalled the app, then did a clean reinstall and copied the entire user Library folder for the app to a separate location so I could copy it back unchanged when the problem occurred.

/Users/my_name/Library/Application Support/Topaz Labs LLC/Topaz Sharpen AI

I then called the app from PhotoLine and, after it worked properly, I did another call and got the error message. I then exited all the apps, copied the folder back to the Library location and re-ran the test. And I got the exact same error message, so it is not a corrupted model file.

For me this is not as big a problem since I can call the plugin from PhotoLine, and the plugin works properly, but if you are using it from Dxo’s PhotoLab you can’t do that unless you call an intermediate pixel editor like Photoshop or PhotoLine first.

Have you filed a bug report?