Enhancement always goes through CPU instead of GPU

No matter what setting i choose, VideoAI always uses the CPU for enhancing the videos and only uses the GPU for encoding the output h265 file. Is there any guides how to force enhancing via GPU ? curious if it will be faster.
Im sporting a 7950X3D and a FE 4090

Settings are:
Preferences → Process → AI Processor: NVIDIA GeForce RTX 4090
Max processes 3
Max memory 95%

Default video settings:
Code: H265
Profile: Main
Video Encoding GPU: NVIDIA

What makes you think the gpu isn’t being used? If you say Task Manager, I would suggest using GPU-Z or HWINFO instead, because the default Task Manager view normally doesn’t show TVAI use of the gpu.

Can you share the logs for reivew?