Encoding Switches From AMD Discrete GPU to AMD Intgegrated CPU GPU

My system has a AMD Ryzen 7950X CPU with the built in TM GPU and a AMD RX 6700XT discrete GPU.

My preferences for processing say to use the AMD RX 6700XT discrete GPU.

I’ll load up a batch job and kick it off, and encoding takes place on the discrete GPU. After encoding 1 or more jobs, the system starts processing on on the integrated CPU TM GPU. Encoding a job goes from 20fps to less than 1fps. I have to manually tell it to stop processing the job and start it again for it to use the discrete GPU.

I’m having to keep checking back every couple of hours to make sure it’s still processing on the Discrete GPU. Letting it run over night almost always shows that it’s switched to the TM GPU.

1 Like

Have you tried or would you consider disabling the iGPU in your BIOS?

I had not considered that. I’ll check to see if my BIOS/UEFI supports that. If I can, that would solve my problem, but this should still be considered a bug though.



Thanks for reporting this issue. Could I take a look at the app’s log files to add to the report item for our dev team to look at?


To gather logs, please select Help > Logging and make sure that there is a check mark next to File Logging. Next, recreate the issue and then return to the Help menu and select > Get Logs for Support and attach the zip file to your reply.

Afraid I can’t as I signed a NDA for some of the content I’m working on and I briefly looked at the content of the logs and I can’t send that information.

I was able to go into the UEFI and disable the iGPU and everything is happy now. Thanks for help in that one.

Completely understandable, we have a similar iGPU + dedicated GPU testing machine in-office so we’ll work on replicating this behavior.