Downloading the new Topaz AI

I can’t seem to understand all that I have to do to load the program. I’m a user and had the old version which worked pretty good. Now I can’t load a photo and I don’t know why. I have a screenprint is any can help me.
Error Message about loading

Steps to reproduce issue:

  1. Step 1 I downloaded the program, and the camera download. I had no clue what to do next.
  2. Step 2 So I opened Topaz AI and it said to drag my photo in (or open it).
  3. Step 3 I tried both ways and got the same error message.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Thanks for reaching out. It looks like the file path for this image is very long. I think it may be hitting the limit for file path which is 256 characters a the moment.

Could you try moving this file to your desktop and try opening the file from there?

I can check with my team to increase the character limit for the file path.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.