Dng files are not good for Adobe lightroom

Hi, I shoot Nikon Z9 and Z8. When I want to process the Raw files in photo Ai2, the dng files that are created and sent back to LR can not be processed like other dng files. The masking doesn’t work as it should and so on.
Also, when trying to process Z8 files in PhotoAi2, the Tiff file created by Topaz looks nice on the library module but when I change to develop module it looks grainy and soft. is there a fix for these problems?

Are you applying the mask before processing with Photo AI? We don’t read the RAW edits and recommend masking after you import the photo back into LR.

I’m not sure why it would look different in the Library module and Develop module. Can you upload the original NEF file so I can test it out on my end using the workflow you described?

Hi, thanks for answering. I never apply anny masking before processing with Topaz software. The 2 issues I mentioned are noticed when I try processing as a plugin from LR to Topaz.
I attach a NEF file for example.
DSC_7808.NEF

‫בתאריך יום ד׳, 27 בספט׳ 2023 ב-18:56 מאת ‪Tim He via Topaz Community‬‏ <‪noreply@topazlabs.com‬‏>:‬

Looks like I don’t have access to the drive. Can you submit a support ticket at support.topazlabs.com using the beacon at the bottom right corner of the page? They’ll be able to help troubleshoot using specific images and info about your workflow/computer much faster than going back and forth in this thread.

https://drive.google.com/file/d/1b3AvrelgkPc8uP_C9Me_pYV7s-lhOZjI/view?usp=sharing

‫בתאריך יום ד׳, 27 בספט׳ 2023 ב-18:56 מאת ‪Tim He via Topaz Community‬‏ <‪noreply@topazlabs.com‬‏>:‬

I use a Z8 and have similar issues. I can’t use masks in Lightroom on the Topaz generated dng file, and the edit options are more limited than with a regular RAW file.

False alarm. Not sure what happened, but when I opened Lightroom today everything was working as it should.

1 Like

Thanks for the update!

We’re glad to hear things are back working for you.

If you ever are experiencing problems and need more immediate support please reach out to us at the following link:

Topaz Labs | Support Page

I have the same issue as stated above. LR does not allow me to used masking when the file is returned as a DNG from Photo AI 3.

Which Lightroom Classic Plugin are you using:

  • The RAW plugin, accessed through File > Plug-in Extras > Process with Topaz Photo
  • The External Editor plugin, accessed through Photo > Edit in > Topaz Photo AI

When you have the DNG file back in LR, go to the calibration section. You will see on the top right corner an option to choose a version, choose the top one.