Dissatisfaction with updates

Though Topaz products accomplish some significant tasks, the user experience is pretty bad. I hadn’t used Photo AI for a few weeks and when I tried to open it for a project, it asked me to authenticate again. Okay, once in a while that is reasonable. Then it told me it had 9 updates. I downloaded them and nothing happened. I downloaded them again, still no action button to install. Tried a third time. Nothing. Then I read through the long list of release notes that said the installer doesn’t work on some Macs! I needed to download and install the full package. I did. Then it wanted me to authenticate again, which I did. All in all, this wasted an hour of my time because your update system doesn’t work well. It was not a good user experience.

There was a bug in v1.2.1 that caused the in-app updater for Mac to not work. If this was the case then it’s not an issue moving forward once you have updated.

If you were not on v1.2.1 before and it’s an issue with a different version please let me know what version you were using and if you are still having issues moving forward.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.