Detail in Studio won't show in the Speciality section

After knowing that deleting the databases will solve issues with new plugins I’m really lookin forward for the next “in Studio” plugin :slight_smile:

Not sure if this will help anyone, but instead of opening an image and validating plugins, I validated first and then opened a file and then everything appeared under Speciality,

Hi Joe,
I was able to solve this problem by using the database tool that was sent to me in response to my support ticket. I also opted to zip my database folder and uploaded it to the Topaz dropbox. I am really grateful for the help

BUT, the procedure was a bit confusing. When I ran the batch program and entered “1” to indicate that I would assist Topazlabs by uploading my folder, the message “Couldn’t find file” appeared in the DOS window. (Another user reported above that he got that message so he deleted all the files manually.) At first I was confused and thought that the batch program didn’t work, but somehow I continued and it did work as expected.

I am only writing this to point out that the process is a bit confusing because of this error message.

1 Like

The script was written to work in most conditions (default install locations, etc.). It’s entirely possible it won’t work 100%, but we’ve seen a high success rate so far. Also, thank you for providing those files :slight_smile:

We’ll get the issue resolved soon enough, so the removal won’t be necessary any longer.

1 Like

Running Topaz Studio V1.4.2. on a iMac 10.9.5

No sign of Detail under Specialty.

Deleated Topaz re-down -loaded nothing still not there.

Tried revalidating plug-ins - nothing

It is there under Adjustments but of course no pre-sets.

Now I can see it in my list in photoshop,under the Filter menu along with Clarity and Impression, Detail is right in the middle but if I try to open it from photoshop, Filters I simply end up in Personal Favourite not in detail.

Submitted a ticket but it was Friday and funnily enough they seem to give their staff the weekend off at Topaz central.

I am on UK time so I am not sure when you will be in. But it is interesting to see others having issues just just me.

Firstly is the login for Studio on the exactly as the Account on the main site at and your PC meets the minimum Technical Requirements and the version of Studio you are running is version 1.4.2?

Yes they do give their staff the weekend off.

Yes, I am logged into the same account.

I am on a Mac not a PC but as far as I can tell, it is running 10.9.5 and has a Graphics chip NVIDIA GeForce GT 750M 1024 MG, so I think I am okay.

The version of Studio I am running is defiantly the latest one I downloaded it again and it is V1.4.2

I have tried everything I can think of. The most mysterious think is it does show up in my Photoshop list of filters but I still cannot get in.

Clarity and Impression are there but not Detail.

What I am asking is if you login to the Studio account do you use the same Login details to login to the Topaz Labs account … i.e. the same email/password combination.

How do I log in to a Studio account?

You mean on the Topaz web site?

Yes I am logged into the same account.

It shows detail on my list in Photoshop so I know there must be a bug of some kind.

If I had done something wrong I don’t think that it would show on my Photoshop list as I did not own it before. Only when I downloaded the Topaz Studio which I did because I wanted detail and it is the one thing I did not get!!

I thought you may have owned the Topaz Detail plugin previously and upgraded as they are held in different accounts.

You will need to wait for support to come back online later today.

NOTE: I deleted you email from your name field as this is a public forum.


I appreciate you taking the trouble to reply to me.

I think this will take the tech team to sort out as I have tried almost everything an user can do to get it to work.

I am sure once look into this they will be able to work out what is going on. My guess - the pre-sets part of Detail is just not downloading.

But then New programs - up dates always have the odd bug that needs working out.

P.S. thanks for removing my email

The other thing you can try is Check for Updates under the Help menu which will attempt to synch the Adjustments or in the preferences uncheck the “Hide Presets Created by Community Users” to see if that helps.


I have done the check for updates thing.

Did not notice that hide presets credited by Community users

Un-ticked it closed Topaz re-opened Topaz still nothing!

I will have to post the answer once the Topaz crew find a way to fix it.



1 Like

Please update to V1.4.4, then try the “Check for Updates” option. You’ll see some feedback that indicates if the update was a success, or if something didn’t work as expected.


Thanks for your help Joe but the people at Topaz managed to fix what had go wrong. And hopefully now with V1.4.4 the problem I found wont be happening to any more people.


Amanda, I am the people at Topaz :wink:

I’m glad things are working for you, now!

thank you so much for sharing this. I had the same problem and the database removal tool didnt help. after deleting the database files on my own, everything is perfect!

1 Like