DeNoiseAI v3.0.2 and Affinity Photo

DeNoiseAI (DNAI) v3.0.2 is not playing nice with Affinity Photo (Win 10).

I just tried to send an image to DNAI from Affinity Photo (v1.9.0), and it doesn’t work. Acts like it’s going to open, but doesn’t. I tried both AdjustAI and SharpenAI and they both work fine. I re-booted and did all the usual song-and-dance with Windows, but no DNAI. Checking Task Manager doesn’t show it running.

Since the other plug-ins work fine, I don’t think the issue is with Affinity Photo.

Works fine from Windows 10, at least for me.

Please let me know what type of image is open in AP that you are trying to process. I have found there are limitations with processing .afphoto composite images if you process single layers if the original layers have different dimensions.

It’s a 15.5MB TIFF scanned from a Canon CanoScan 9000F. And yes, Win 10 home.

Since my original post, I learned there was an update to AP, to v.1.9.1, downloaded & installed. Then I uninstalled DNAI, then re-installed. Still not working. I get the usual brief flash screen saying I’m using a plug-in, then it’s gone, nothing happens, nothing shows in Task Manager.

On the chance that there is an issue with the scan, I just exported a new TIFF from NEF using NX Studio Studio, and the problem persists. I also tried an unmodified Nikon JPEG, same problem.

So one more test: the scanned TIFF in AP, duplicated, sent to Topas Studio 2, DNAI ran just fine, applied the tweak, sent back to Studio, another tweak or two, sent back to AP.

OK it may be that your image is a Grayscale image from the scanner, they are not supported because of the differences from RGB images. But AP should block all Grayscale images from being sent to all Plugins.

If you want me to check the image just upload it to a file sharing site so I can download and check.

For the NEF to TIF and Nikon JPEG please attach the images to a support request at the main website as I have heard other apps having issues with files from the latest version of NX Studio. Have you tried opening these using DeNoise/Studio in standalone mode?

Nope, color scan, not grayscale. AP will send the file to Adjust AI (v1.05) and Sharpen AI (v2.1.3) no problems. Same with the NEF to TIFF. And the JPEG was the Nikon SOOC file, not processed externally from the camera.

No problem opening any of these in DeNoise via Studio 2.

I can open the Nikon TIFF and the scanned TIFF in Olympus workspace with no problems. (Not something I would want to do, just saying.) Same with PEN-F ORF to TIFF via Oly Workspace, open just fine in Nikon NXStudio.

It’s been a couple of years since I uploaded anything to a file sharing site, and that was Google Drive and I’m pretty sure they shut me down for lack of use.

Regardless, I’m thinking the problem isn’t with the images, it’s something in my system. Either I’ll figure it out, or the next update will resolve the matter.

Thanks for trying to help, much appreciated.

1 Like

I’m suspecting the issue may be with the DNAI plug-in and Affinity Photo. Here’s what I’ve just gone thru:

After a couple of uninstalls/re-installs, I finally did a complete uninstall using Hi-Bit Uninstaller, that removed everything incl. registry entries. I had been using the the full installer, so I d/l’d the on-line installer, disabled my firewall temporarily, manually created a firewall rule for DNAI, then ran the installer. Installation & re-registration done. That didn’t fix anything.

Nikon NX Studio allows adding external programs, just like FastStone, and like FS, it’s the .exe version. It ran perfectly fine in NXS, I applied the tweak and sent it back to NXS. The resulting TIFF is the same as running it thru DNAI stand-alone. Unfortunately, it only works with NEF files, not converted TIFFs.

I can send my image from AP to Topaz Studio 2, run DNAI, then back to AP for further editing, or process the image in DNAI first then take it into AP. Hopefully a future update to one or the other will resolve this.

I’m not experiencing any problems here with Denoise AI 3.0.2 working as a plugin from Affinity Photo on Windows 10 Pro version 20H2 Build 19042.867.

Have you tried removing and replacing the Plug in search folder path in Affinity Photo to Topaz Labs LLC, (Edit->Preferences->Photoshop Plugins), and have you ticked the “Allow Unknown plugins to be used”. You will need to restart Affinity photo after making the change.


The Affinity Photo Denoise AI plugin is handling both 48 bit (RGBA/16), and 24 bit (RGBA/8) color scans from a CanoScan 8400F scanner (scanned using VueScan v9.7.50) , RGBA/16 files developed in Affinity Photo from Nikon .NEF files, and 24 and 48 bit TIFF files exported from ACDSee Photo Studio Ultimate 2021, as well as the normal run of JPGs etc.

Just as a thought, you might try checking the file hashes for the Denoise AI plugin file. Its default location is C:\Program Files\Topaz Labs LLC\Topaz Denoise AI\PS _Plugins_x64. The filename is tltopazdenoiseaips_x64.8bf and the file hashes are:

SHA-1: 23F4FCE25595021C195671E115674CBEC1B0D4C7
MD5: 7D0547024443D5FAC838BEA1D1BC5E9C
CRC32: D304F4D4

Thanks for the info & help, Greyfox. The SHA1 hashfile is fine. The path to the 64-bit PS Plug-in is correct, except it wasn’t, somehow I had two entries for DNAI – Ooops! I removed one, restarted AP, but that didn’t help. “Allow unknown” box is checked, as usual.

So there’s obviously something cranky on my system. I really don’t want to do a total uninstall of AP like I did with DNAI, then re-install, but at some I may give it a go.

But I am baffled by the fact that Adjust AI (older v1.05) and Sharpen AI (older v.2.1.3) both load & process fine. And when I try to load DNAI, it doesn’t launch, but AP shows “plugin” in the history panel. Further mysteries.

Anyway, thanks again for the suggestions.

I’m having the same problems, but also, Studio 2 updated is quitting on me! I’m using a MacBook Pro, and I’ve sent them the info they said they needed, but this is TRULY UNACCEPTABLE! Unfortunately, the Sharpen AI is doing the same thing, and I’ve had trouble with the last 2 updates, although I was able to finally get them installed and get them to work, I don’t understand why, after all these years of flawless installations and updates, this is happening now!

No need to duplicate posts, once is enough. And, asit is in the hands of Topaz Support, they should get back to you soon. Have you read the notices on their support page?

Just to make this easier for everyone.

Known Issues

SHARPEN AI 3.0 CRASHING ON MacOS 10.13 OR 10.14: We are aware that some users are encountering a crash on older MacOS devices when using Sharpen 3.0. Please uninstall Sharpen AI 3.0 and reinstall version 2.2.4 from this link: Sharpen AI 2.2.4 for Mac . We will have an update to address this in Sharpen 3.0 the very near future.

SHARPEN AI OR DENOISE AI 3.0 “ERROR PROCESSING” MESSAGE: If you receive a message that recommends updating your driver or changing your AI Processing preferences, please update your Nvidia or AMD graphics card driver directly through Nvidia or AMD.

PHOTOSHOP PLUGIN NOT WORKING ON M1/SILICON MACS: If you recently updated your Photoshop to version 22.3 on your M1 device and can no longer see our plugins please know there is a conflict between Adobe and Apple preventing the use of our plugins on M1 devices. While waiting for this to be resolved, you can revert back to the previous version of Photoshop if necessary and our plugins should function again. Thank you for your patience while we await Adobe and Apple’s changes.

BIG SUR SUPPORT: Adjust AI and Jpeg to Raw AI are still awaiting updates to support Big Sur at this time. DeNoise AI 3.0 and Sharpen AI are now supported on M1 devices except Photoshop plugins (see above).

BIG SUR SUPPORT: Adjust AI and Jpeg to Raw AI are still awaiting updates to support Big Sur at this time. DeNoise AI 3.0 and Sharpen AI are now supported on M1 devices except Photoshop plugins.

I hope these two plugins will be updated for Big Sur soon. Adjust AI was once very important in my workflow. I miss it!

1 Like