DeNoise update to v. 2.3.5 crashes Mac Book Pro... Big Sur & Intego

The current 2.3.3 version running on my Mac Book Pro is stable on Big Sur. However, trying to update to the latest version (2.3.5) causes an immediate system stop/crash and restart of my system. Anyone who have experienced the same or may have a work around? Thanks in advance!

Are you using the built-in update function within the app or downloading a full version from the Topaz website? At what point is the crash occurring? Is it during the update process, as you imply, or when you try to open DeNoise 2.3.5?
I have updated to 2.3.5 on Big Sur (from 2.3.4) without issue.

1 Like

are you by any chance running Norton Security or 360 ? I had a similar problem with my MAC crashing using the online updater. I removed Norton and the problem no longer occurs.

1 Like

Thanks for your reply! I have tried both! The crash occurs during the update process. Maybe I should try to update to 2.3.4 first!

Thanks for a fast answer! No, I use the Intego security software. But, good proposal, I can try to turn it off during the update process!

Download and try the v2.3.5 full installer from the product releases section and use that…

https://community.topazlabs.com/c/releases

1 Like

Thanks for the tip! I had already tried this, unfortunately with the same result.

I have tried to install the update with all other running programs stopped (firewall, virus control, etc). No improvements, the mac still crashes at the beginning of the update process. I haven’t tried to deinstall anything yet (not sure if that makes sense!)
Following software is running at start of my MacBook Pro:

  • Back-up & Sync
  • Spyder Utility
  • Qfinder Pro
  • CleanMyMac
  • Intego Software (NetBarrier, Virus Barrier, etc.)
  • Adobe CreativeCloud

I have a late 2013 15" Retina MacBookPro with 16GB of memory, 1TB NVMe M.2 SSD (updated with adapter), 2,3 GHz quad core Intel i7 processor

Raise a support request at the main website please. We don’t seem to have any other reports of the installer

The only thing I think may cause a problem is Intego, so you may want to turn it off before installing.

1 Like

ok, thanks for the advise! Turning off Intego had no influence.

1 Like

Uninstalling the Intego Software did it! I thought stopping the various programs would be sufficient, but I had to uninstall the complete Intego X9 bundle. After installation of the DeNoise update (full installer), I reinstalled the Intego software bundle and tested DeNoise which is running fine! Thanks for good and fast advises!

1 Like

I’m glad you got it sorted. I guess you should report this to Intego, since it might be creating the same issue with other apps.