DeNoise AI problems with operation from LR

I would like to add another apparent bug in Denoise AI v1.1.0. Running on a Win10 computer, using Edit In from Lightroom Classic. When the image file (16–bit Tiff in ProPhoto at 300ppi) is processed the Apply button in the lower right corner is “grayed out” and does not work. Nor can I save the image back to LR by using Ctrl-S. It is possible to Save As, but then I have to sync the folder in LR to re-import the processed file.

I found that too, but only if you open AI via Lightroom. You can get the Apply button to work but you have to make multiple big adjustments to the sliders until it decides to work. A bit frustrating.

I also find having to change colour space every time I open Topaz a chore too. IMHO it should default to whatever Lightroom is using, or at least allow you to set what the default colour space is.

The way to save to the existing image is by using File-> Save or Ctrl+S. Your ICC Profile is only available to change when using Save As.

Again, the File->Save or Ctrl+S do not work, nor does the Apply button. The only option is File->Save As.

I also wish that the Save As options were sticky, so that I could specify file type and color space and have them become my defaults.

You will need to update the preview at least once before being able to Save the result either with File-> Save or using the Apply button. You will see a option like this on Windows and should be similar on Mac:


Using Save as creates a copy where you can specify the type @ ICC Profile but it won’t be re-imported into LR, you would need to do that manually.

I had the Update Preview set for automatic update. While the preview did get updated the Ctrl+S and Apply buttons were not available. I then tried using manual preview update and the Apply button worked after that, regardless of whether I used manual or auto update of preview.

So, I believe there is a bug, in that no matter how many times the preview is updated automatically, the Apply button does not work. It does take changing to manual update to trigger the use of the Apply button and Ctrl+S.

Please raise a Support Request at the Topaz Labs main site.

The newer version has fixed this problem.

1 Like