Denoise AI issue

I’m using the latest Topaz Denoise AI 3.7. It’s been working fine for ages (plugin in Photoshop) but today there’s an issue:
It doesn’t matter whether I select “standard” “clear’ low light” etc, after the processing i get a message that the program has stopped working. However, when I view the image in Photoshop it has been processed. This is happening in the standalone as well.
I uninstalled the program and reinstalled using the full installer…issue remains. I also tried installing an earlier version…which worked…then updating to 3.7, but the issue came back.
Also, a couple of times the issue did not occur and the image processed as normal.
The only change I have made to my computer is to install Tony Kuyper’s TK8 panel…but PhotoAI and Sharpen AI work fine.

Go to Help, Graphics info., Press the Copy button and paste the info here.

Thank you for the reply. Graphics info:

Application & Version: Topaz DeNoise AI Version 3.7.0
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 516.94
CPU RAM: 32710 MB
Video RAM: 6144 MB
Preview Limit: 7843 Pixels

Try updating your NVIDIA drivers to the latest version from the NVIDIA web site to see if that helps.

If there is no change you will need to raise a support request at the main website.

Thanks again. For the moment, at least, the issue seems to have gone. I did a disk clean up…seems to have worked. Not sure updating the drivers would help as it was working one day not the next…same drivers, same software…can’t see how the drivers could be the issue. Could be wrong though…lol