Denoise AI - Exif being Stripped

Since the latest update last week it seems the EXIF is once again getting stripped. This was fixed in the previous release but sadly seems to have returned.

I am not seeing that issue calling DeNoise AI from Lightroom 6. Please raise a support request at the Topaz Labs main website with the original EXIF and what is returned … giving the image as an example for the engineers to look at would also be good.

@phill

Ex camera JPG’s from two different cameras processed here in Denoise AI, v 1.2.0 and exported as 8 bit TIF, no compression have correct Exif details according to ExifTool.

If you can state what type of source and export formats you are using, and maybe specifically what Exif data is missing, I could run a comparison test here.

Thanks. I have raised a support ticket. I have attached and original CR2, an edited .tiff and a short screen recording showing the problem with all the versions of my software/hardware etc. Hopefully that will provide enough information. It could be unique to me, but it was working with 1.1.1.

1 Like

As there is no update on my ticket yet I had a play today. If I invoke Denoise AI from Lightroom then it does the create duplicate file and when you hit apply you can watch the metadata vanish. If I export the same CR2 to Photoshop CC then invoke Denoise AI, the metadata stays intact. So there must be something going on with the interaction between Denoise AI and Lightroom. If I examine the result in RAW metadata from the files after using Denoise in LR and PS, the LR one ends up at 17.2K while the PS one ends up 20.4K.

Many thanks to the devs. The latest 1.2.1 update fixed the problem

I’m glad your update solved the problem. However, I still have the EXIF lens info stripped in the tif. I’ve installed 1.2.1 and in LR preset setup I’ve selected the DeNoise icon, etc. It launches 1.2.1, edits fine and hitting “Apply” returns me to LR (6.14) with the Edit-tif extension. However, the lens profile isn’t found although it shows up correctly in the unedited NEF.
Only weirdness is that the “Edit In” window shows DeNoise AI as well as Topez DeNoise AI and Topez DeNoise AI.exe just below Photoshop in the separate pane above the other Preset list. I see no way of cleaning that up although I don’t expect it should make any difference.

Any suggestions would be appreciated!

Marty

I think it is normal that after performing denoise that the lens profile is no longer present, this is because it is no longer valid and could if I understand correctly cause odd things to happen. However, all the lens details etc still remain in the EXIF and you can see them when you look at it. At least you can on my setup.

OK, I think I’ve got it sorted out although it sure could be more straight forward. On my machine the Library tif file (post DeNoise editing) DOES show the correct Lens data. However, moving that file to Develop DOES NOT and Enable Profile Correction is grayed out with the inaccurate (grayed out) lens profile selected.
DeNoise really shouldn’t affect the Lens profile interpretation but so be it. At least it appears (the two files look exactly the same) that the correct profile is being employed.

DeNoise does not affect the lens profile interpretation, Lens Profiles are only applied to RAW files in any RAW Converter. You can do manual adjustments though.

Makes sense. In terms of workflow, it would appear that the “Enable Profile Correction” should be “checked” before the edit in DeNoise. Is it correct to assume the Lens Profile is maintained after DeNoise returns me to LR? I say this because (and maybe a question in a LR forum) it’s a mystery to me that LR correctly identifies the lens (NEF) but the edited tif does not and offers a very minimal set of lens choices, rarely including any of mine.

It is all normal. LR is trying to make a best guess as to what it can do with a tiff. Best routine is to always apply lens corrections at the start. Make all other basic adjustments such as shadows, highlights, black point, exposure etc but leave sharpening, clarity and texture. Then apply Topaz AI. Finally do the rest of your adjustments.

Sure, DeNoise doesn’t remove the EXIF info, just that LR only applies lens corrections to RAW images as all RAW converters do.

You are right in assuming lens corrections should be applied at the start because they attempt to correct barrel or pincushion distortion if any, chromatic aberrations and light falloff.

But you can also apply manual corrections at any time.

Thanks for all the great info! Trying not to be OCD but do we rely on DeNoise Sharpening to completely replace that function in LR by reducing the LR Sharpening to zero (which is not the default) upon import to Develop and then ignoring that slider?

DeNoise does not Sharpen images the Enhance Sharpness slider is used to sharpen images that may have become blurry from the effect of noise reduction as the Recover Detail slider can also be used to recover details that may have been lost during the noise reduction process.

Lightroom default Sharpening is typically seen as the RAW pre-sharpening so it can be left as it is but Noise Reduction should be set to 0 for both Luminance and Color before invoking DeNoise AI or indeed any external noise reduction application.

1 Like