DeNoise AI 2.3.3

Download:

Change log:
v2.3.3 (October 26th, 2020)

  • Updated OpenVINO libraries on Windows
  • Changed ownership unverified prompt so it prompts for login instead of quitting
  • Fixed XMP metadata not writing when saving as JPG
  • Fixed a frequent crash on Windows when opening the app multiple times
  • Fixed auto loading very slowly in certain cases

v2.3.2 (October 13th, 2020)

  • Updated OpenVINO libraries
  • Fixed potential crash when using post processing on large images with AI Clear
  • Fixed authentication looping forever for certain users
  • Fixed processing running twice in some cases
  • Fixed multiple openings not adding files to initial window on Windows
  • Fixed potential crash when opening another instance
  • Fixed case where excess memory was being used during some processing
  • Fixed certain message boxes not displaying correctly
  • Fixed navigation panel jumping when clicking outside the box
  • Fixed GPU memory defaulting to nothing in some cases
  • Changed OpenVINO toggle to be disabled instead of invisible when OpenVINO fails to load
  • Changed navigation panel hover cursors
  • Changed Chroma Noise Reduction to go from 0 to 100 instead of 0 to 1
  • Changed in-app updater to run in minimal mode to simplify updating

v2.3.1 (September 28th, 2020)

  • Fixed crashes in networking code
  • Fixed a crash when using the brighten feature on large previews
  • Fixed a crash in benchmarking when OpenVINO wasn’t enabled
  • Fixed a crash in auto settings when the program cannot setup the AI model
  • Fixed preview panning requiring two clicks
  • Fixed split view slider not tracking with mouse under 100% zoom
  • Fixed some cases where the application was incorrectly running on integrated graphics
  • Temporarily disabled GPU optimization due to slowdown issues on 1600 and 2000 series cards
    – We are looking into making this work for all cards, but in the meantime we don’t want users to have an inadequate experience with the feature

v2.3.0 (September 23rd, 2020)
Major features:

  • Added comparison view, which allows you to compare 3 modes at once
    – You can find this under view modes, or the View menu
  • Added GPU optimization for Nvidia cards
    – This can be found in Preferences > Advanced
  • Added new model that does no sharpening
    – To use this model, use Low Light mode with 0 sharpening
  • General AI model improvements

Other changes:

  • Changed the interface for the initial open images screen
  • Changed right panel so that it disables instead of hides itself on initial load
  • Changed minimum sharpness for DeNoise AI to be 1 instead of 0
    – This is to highlight the new no sharpening model
  • Moved Low Light from under DeNoise AI and made it its own top level mode
  • Added a crash reporter which can automatically log crash information
  • Added the ability to drag and drop folders to import images
  • Added a color change on the drag and drop area when dragging images onto it
  • Added new sample images on the initial open images screen
  • Added ability to use the mouse wheel on sliders
  • Added ability to pan on all preview windows, not just the original
  • Added a way to delay the showing of license upgrade and program update prompts
    – This change has been backported to previous minor release (2.2.12)
  • Fixed an issue that made holding down an arrow key to change a slider reset it to default instead
  • Fixed color profile selection coming up in the save dialog when not appropriate
  • Fixed some minor UI spacing issues
  • Fixed grid artifacts when saving images
  • Fixed crashes due to large images when using post processing sliders
  • Fixed a crash when saving in some cases
  • Fixed arrow keys messing up the right control panel
  • Fixed some instances where the preview would not proc if it was queued after a previous one
  • Fixed OpenVINO loading non-OpenVINO models in some cases
  • Fixed scroll bars showing up on the file list view and right panel controls when not needed
  • Fixed the plugin and external editor file menu accept button not working
    – This button was also renamed to Apply to match the buttons
  • Updated Qt to 5.15.1

Known Issues:

  • Photoshop last filter option will not save Low Light settings
    – We are working on updating our plugin to a new Adobe SDK version which should resolve this
  • Occasionally, the right panel and selection indicators in comparison view will switch rapidly when processing
    – This should be fixed if you pan or click on one of the non-original previews
    – This is just a visual artifact and does not break anything
  • Changing a slider via the mouse wheel will not turn off auto toggle
8 Likes

Thanks Adam!

I’m tooting the Topaz horn!

http://plugsandpixels.com/blog/just-released-topaz-denoise-ai-2-3-always-discounted/

1 Like

Artifacting seems particularly high for the DeNoise model, note that Low-Light will fix it but the effect is quite pronounced (No Sharpening makes no difference):

Studio image produced for Hi-ISO testing, RAW ISO25600:

1 Like

Looks like there is no possibility to make a split view between the original and processed images? Am not sure how the “comparison view” mentioned in the release notes is implemented…

Click on the “View” icon at the top and you’ll see four options: Single, Split, Side-by-side and Comparison.

Can we install a trial version 2.3 without erasing our current licence one ?

Download the installer and try to install to a different location. But I suspect it will treat it as an upgrade if you have an existing copy installed.

Otherwise raise a support request at the main website and ask there.

I would say this model is not made for images with color noise.

It does better with images that are already denoised and sharpened with LR, C1 or others.

Bug:

Plugin Win 10.

When i want to move the preview it works only after the second klick.

Before after locks with the mouse.

It is asking me to pay $49.00 - I hope not! :frowning:

Hi Jack, Check with support …

1 Like

This has been addressed. Currently batching a few things into the next release.

It says I own 2.2.9 - and have to Upgrade to 2.3.0 because my 2.2.9 ran out August 31st?!

Good to known Just purchase the upgrade to 2.3 , looks starting as licenced but I am getting the login box to register every time I launch it . So just I need to close it
Just a few discrepancies :
with the cursor on the split view and one crash while updating but nothing dramatic and I am confident and wait the next release

I purchased an upgrade this morning. Downloaded and installed the software from your site. EVERY time I launch the new app I get the message to renew my license. I login and it does not recognize me. What can I do??

Thanks.
Curtis

I’d recommend you contact support directly to handle any account issues. I looked at your account’s status and it looks like you didn’t purchase an upgrade (or at least not with the e-mail associated with this forum account). If you purchased the wrong thing or it went to the wrong account support should be able to fix it for you.

Thanks. I hope they reply as quickly as you did!!!

1 Like

I just upgraded to 2.3 and noticed the following issue:

When mousing left and right using the split screen, the dividing line doesn’t follow the mouse movement and generally skips around.

2 Likes

Upgraded on Mac, standalone Editor. iMac Pro w/ Vega 64X (tested both CPU and GPU accelerated)

Bug: Left Click to switch between original and denoised version only works on first click, doesn’t switch back to denoised. Sometimes on manual preview update the preview doesn’t switch to denoised at all (have to move the view around and trigger another manual preview).

Worse algo for me: low frequency color and luminance noise get’s less denoised on low light mode. Pictures I could rescue before would fail now :frowning:
(Sony A9 RAW pushed really high to ISO 25-50.000, exported from LR with color and luminance denoise set to zero (which worked best for me until now))
-But- the AI Clear Algo seems to handle this extreme noise better than before (with some other drawbacks regarding details)

2 Likes

An irritating issue - clicking on a processed image preview brings back noised original, and it’s needed to move the image a little at least to recompute the preview. :slight_smile:
Hi-Fi model, as for now, in unusable - artifacting, and it’s not chromatic aberration, it looks rather like horizontal multi-repeating the “contrasty” edges with a rainbow. :slight_smile: