DeNoise 3.0

Can you report this in that beta thread? If it gets fixed there I can pull it into DeNoise after.

1 Like

Will do.

Uninstall and full installer worked. I’m just wondering how to detect this in Beta tesing - Perhaps the production upgrade could be issued to beta testers a day before general release?

As an OpenVINO user, I am extremely disappointed to see that version 3.0.0 of the app removes OpenVINO support.

I am also extremely disappointed to see that Topaz have done this without any warning or announcment to users.

I can see that the 3.0.0 “full” installer is less than half the size of the old “full” installer.

I can see that the tgrc folder no longer contains OpenVINO model files.

Processing is extremely slow and no longer utilizing full CPU speed:

dnai_cpuz

And the application no longer performs “benchmarking”. While there are still registry keys for OpenVINO, they appear to be vestigal and no longer do anything. Previous versions would set (after benchmarking):

“cpuPlugin” to “0”
“ifOpenVinoCanWork” to “true”

Version 3.0.0 keeps “cpuPlugin” at “1”, “ifOpenVinoCanWork” at “false”, and ifTFGPUCanWork at “true”

Can the devs please clarify the future of OpenVINO in your applications. I am in the process of setting up a 16 core server for running VEAI in OpenVINO and this development is extremely alarming to me as an OpenVINO user.

1 Like

OK, so the above is for the legacy installer in Windows 7.

I tried the Windows 10 installer on Windows 10, and the OpenVINO model files are there.

So, it appears OpenVINO is now only supported in Windows 10, and is removed in the legacy installer.

This is an important note that should be mentioned in the change log.

I would imagine this would have been the case in beta as well, or something has changed which I am not aware of. We’re looking into it. Right now I believe the issue is the online installer somehow deselects both the legacy AND non-legacy resources when running on a legacy machine. In the end that leaves legacy installs without the models required to run. However the full installer drops it right every time since it doesn’t deal with the turning stuff on/off shenanigans. This may also be hard to detect in beta unless you do a full uninstall/reinstall every time as if the models were ever there you wouldn’t notice them not dropping the next time.

I’ve asked @suraj to see if he can explain this better, but it looks like that’s the case. I’m not sure what limitations are in place or if there are plans to do anything in the future myself. On the legacy machine, have you checked to see if there’s an iGPU option under processors in preferences? Would be labeled like “GPU: Intel 630 UHD” or something along those lines.

There isn’t. Just “1: Default GPU”. It’s a GPU-less VM.

I should have waiting before posting, until I tried to run the program.

So, while I got Denoise AI installed under Windows 10 and can see the OpenVINO model files, it does me no good, because Topaz Denoise AI 3.0.0 refuses to run.

I see a blank white window, then the program just exits with no error message.

I suspect that it is not running because this is a GPU-less VM running on a hypervisor. So as I always ask in these cases, what is the point of supporting OpenVINO, if the program cannot run without a GPU? If a GPU and GPU drivers must be present, then the GPU processing will be MUCH faster. OpenVINO = pointless.

Can this be fixed? The legacy version runs on a GPU-less VM running on a hypervisor, but without OpenVINO support.

UPDATE

Guess what…

I GOT IT TO WORK.

I made the incorrect assumption that you are using the DirectX 12 Software Renderer for Windows 10.

But you’re not. You’re still using OpenGL.

topaz_opengl

So, it simply means that it needs to use the same setup that it always has on Windows 10. It needs MESA copied into the application directory. It also no longer calibrates… the user needs to go into Advanced Settings and change the AI Processor to CPU. It will then work for OpenVINO on GPU-less machines.

I am EXTREMELTY SORRY I wasted your time with this. All I needed to do was set it up like I always have in the past, on Windows 10.

 
Just to document it, here are the full steps:

 
𝟣. The following environment variables MUST be set:

Right Click “This PC” or “My Computer” on Desktop -> Properties -> Advanced System Settings -> Environment Variables -> New

First Variable Name: MESA_GL_VERSION_OVERRIDE
First Variable Value: 4.2COMPAT

Second Variable Name: MESA_GLSL_VERSION_OVERRIDE
Second Variable Value: 420

Set the above two variables for BOTH User AND System.

Reboot.

 
2. Download Mesa.

At the time of this writing I downloaded mesa3d-20.3.4-release-mingw.7z. (Later versions have issues with missing Vulcan dll files, so it’s recommended to avoid them for non Vulcan applications until they have those issues fixed. I recommend 20.3.4; earlier versions should also work.)

Extract the file. Install and use the freeware 7zip application to do so, if you need it.

You only want two files from the archive: x64\opengl32.dll and x64\libglapi.dll. Copy these into the Topaz application directory. So for Denoise AI, copy them to C:\Program Files\Topaz Labs LLC\Topaz Denoise AI, if you used the default install location.

 
3. Run the application (Topaz Denoise AI), it should now load and use the MESA llvmpipe software renderer. You can confirm by going to “Help” -> “Graphics Info”. It should look like the above screenshot, and show that it’s using llvmpipe.

 
4. It appears that newer Topaz applications no longer run “calibration”. They’re set to use GPU by default. If there’s no GPU, then the application will just exit when the preview tries to run. If the preview is set to “auto” (which it is by default) then that means it will happen as soon as an image is loaded. So you need to go to “File” -> “Preferences” and set “AI Processor” to “CPU”.

 
𝟧. The Topaz application should now run on a GPU-less workstation, as well as a VM/VPS.

 
I haven’t checked everything yet, but it’s working for Denoise AI and Sharpen AI. I believe it will work for all other Topaz Applications except Video Enhance AI, which should run immediately after installing without needing to copy files into the application directory. I haven’t tested to see if not having the above environment variables (MESA_GL_VERSION_OVERRIDE / MESA_GLSL_VERSION_OVERRIDE) makes a difference for VEAI, but I don’t think that it does.

There are some versions of Topaz Applications (again I haven’t checked everything obviously) that run without needing Mesa files copied into the application directory. Denoise AI 2.4.x and 3.0.0 “Legacy” on Windows 7 are like this. They use an old version of llvmpipe (5.0) which appears to be built in. I’m not certain in these cases if environment variables need to be set (MESA_GL_VERSION_OVERRIDE to 4.2COMPAT and MESA_GLSL_VERSION_OVERRIDE to 420), but I suspect that they do. I haven’t tried removing them and then installing and running Denoise AI 2.4.x or 3.0.0 “Legacy”.

Again, I’m VERY sorry for anyone’s time I may have wasted with my incorrect assumptions about Topaz applications using the DirectX Software Renderer.

We’re getting a lot of the new performance boosts out of using the latest versions of inference libraries like OpenVINO. However, these latest versions also tended to require the latest or near-latest versions of the OS.

So we created the legacy versions of the app, in order to ensure that our users on older OS’s could continue to benefit to the improvements we are making to the product. Unfortunately this also required some tradeoffs in installer size, and so we’re dropping OpenVINO on those legacy versions, in favor of Tensorflow.

We DO still support OpenVINO, and if you are running Win10 you should be able to get the full benefit from using it.

We don’t officially support virtual machines running on hypervisors… And we don’t include them in our testing.

But we can certainly take your feedback into consideration. We’ll see if there’s a solution that we can come up with.

This appears to be the same problem that Video Enhance AI 1.7.1 had. It also produced a blank white screen on Windows 10, and had similar x64dbg logs (looped endlessly with C0000005 access violation). It appears to be an issue with the application trying to use the DirectX software renderer (d3d10warp.dll). There are 4 different points in the x64dbg log where it tries to load d3d10warp.dll and it immediately unloads each time. (DLL Loaded: 00007FFBF37C0000 C:\Windows\System32\d3d10warp.dll . DLL Unloaded: 00007FFBF37C0000 d3d10warp.dll)

Whatever the problem was, it was fixed in Video Enhance AI 1.8.0. The latest beta of VEAI continues to run well on a VM, with OpenVINO also working well.

I believe that Denoise AI would also crash the same way on a non-VM (desktop or notebook) computer with a basic non-3D accelerated display card. In other words, it’s not a VM issue, but an issue with running on a computer without a GPU.

I had made a ticket regarding VEAI 1.7.1, it’s ticket number 266711. It might be helpful to ask the VEAI developers what they did to fix the problem, as it looks to be a similar issue here.

Update - The above is completely wrong. I made the assumption that since there are separate versions of Denoise AI for Windows 7 and 10, that Windows 10 must be using the DirectX 12 Software Renderer on GPU-less workstations. This was my understanding of the case with Video Enhance AI, and why it no longer supported Windows 7. Since OpenVINO is no longer supported for Denoise AI on the Windows 7 Legacy version, this led me to believe that something similar is going on with it, so I thought it must also need DirectX 12 for OpenVINO.

This is not the case. The Windows 10 version of newer Topaz applications like Denoise AI 3.x still use OpenGL, and will run just fine on GPU-less Windows 10 workstations if MESA files are copied into the application directory, environment variables are set, and the “AI Processor” is set to “CPU” in Preferences. It will then use llvmpipe.

Hi Brad, issues doing clean install (removing registry entries and all directories):

  • Icon fails to appear on shortcut:
    image

  • Clicking on Change Icon you get the following message:
    image

  • Clicking on browse, to change the icon it takes you to the Sharpen AI Beta directory:
    image

  • Then in the DeNoise install directory there is no “.ico” file as the icon is held in the EXE.

Other issues:

  • If all is removed before installing it only asks if you wish to Buy, maybe it should ask you to login as well:
    image

This is from a TIF/ProPhoto RGB image, colors are not right with the DeNoise and Low Light models:

I use the quad preview feature and its significantly slower updating doing the update than it was in previous versions, at least 3-4x slower. Windows 10 x64, 128GB RAM, 2080 Ti, AMD 3970. Any suggestions on getting back the lost speed short of disabling the previous?

@adam.mains Hair Test Look At Denoise Model.

@brad.ito Brad Look at the eye Lashes of the cat on top of the eyes (right eye) look at the black.Low Light and Clear do not have this problem.

1 Like

Comparison view updates are extremely fast compared to the previous version.

Stunning processing speeds, the image shown here is a RAW from a Sony DSC-RX100M3 at ISO 800 took 18 seconds to process using Low Light model. Unfortunately though, the RAW conversions are simply not up to scratch as you can see here (TIF/ProPhotoRGB output from DeNoise on the left) where the colors are dull with color shifts and lens corrections are not applied. On the right is output from Affinity Photo:

@AiDon This working in AffinityPhoto ?

Thanks @AiDon ! We can replicate this issue, and will get it fixed.

We had to do some re-working of the installers to support the legacy systems, and it appears that it caused some issues that fell through testing.

1 Like

I’m having problems with Denoise AI and Sharpen AI. When I install Denoise AI 3.0, Sharpen AI won’t open and when I check installed programs it isn’t there. When I install Sharpen AI, Denoise AI won’t open and appears to be uninstalled as well. Has anyone else experienced this?
I am on Windows 10.

What working?