Current image has its FACE (Recovering option) of the previous one been copied into

I’m not sure if it has been addressed to in both releases of July, since this is what I came across in the version before that.

It’s hard to reproduce, but it happens after a while, and definitely not right from the start.

Photo AI sometimes mixes the previous converted image with the current one.

Quite remarkable, and probably a useful hint, that it only does it with a face. It seems to reload and mixes the face of the previous image with the current one.

So let’s say that image 1 has the Face Recovering activated, and does its job. Then image 2 gets “disturbed” by remainders of the face of image 1.

Restarting the program solves it (, yet temporarily).

I have a feeling this may be an issue of not cleaning up the Face Recovering memory.

I have a desktop computer with more than sufficient specs:

Operating System
Windows 11 Home 64-bit
Intel Core i9 9900KF @ 3.60GHz 29 °C
Coffee Lake 14nm Technology
32.0GB Dual-Channel DDR4 @ 1066MHz (15-15-15-36)
Gigabyte Technology Co. Ltd. Z390 GAMING X-CF (U3E1) 32 °C
LG HDR 4K (3840x2160@60Hz)
4095MB NVIDIA GeForce RTX 2080 SUPER (PNY) 30 °C
931GB Samsung SSD 870 QVO 1TB (SATA (SSD)) 23 °C
931GB Samsung SSD 970 EVO 1TB (Unknown (SSD))
Optical Drives
No optical disk drives detected
Realtek High Definition Audio

Please send two files that this happens with. I’d like to reproduce this.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Topaz Photo AI should be clearing the previous image information. I’ve seen cases where there is security software on the computer that prevents this from happening.

Do you have antivirus, firewall, or any software that would prevent the cache from clearing?

How often does this happen?

Hi Lingyu,

I have uploaded a few files. In the .txt I have explained that although I tested 50 images I could NOT reproduce it.

Will it occur another time (when I don’t look for it), I’ll get back to you.

Just the memory usage went up quickly, but stabilised eventually.

Best wishes,

Sydney Pais (Amsterdam)

Next time it happens please get the logs.

Open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option. Attach the most recent 3 log files that you can see in the window that opens.

We will look into the issue.

Hi Lingyu,

It occured again. Pls. open a (new?) Dropbox line, and I will send the logfiles, the image and a textfile with additional information.


Same Dropbox as above.
Dropbox File Request

I have uploaded the files.

Thanks, I’ve confirmed it. However it’s still not clear what’s causing the issue.

How much is this impacting your work?

You’re welcome.

It’s not of a great impact, since, as I mentioned before, you can do a restart and the problem has - for that moment - been solved.

But it is annoying and I think it doesn’t look nice for Topaz.

So I hope you will find the cause.

I have not been using heavy software during this process. Just a browser (Tor/Firefox), a pretty light Photo Editor (PhotoFiltre), and the Windows Explorer. So no heavy demands on resources.

Good luck!

Even with the latest update the problem still occurs.

It seems that it can’t handle larger sized images appropriately.

Yet it always takes some time before it gets to that point.

Restarting apparently clears the memory (could it be an memory overflow issue?) and dissolves the issue.

If this is a cache issue, how many files are you processing in a batch to get this behavior?

No batch at all. It’s just one file being opened, processed, then saved.
Then the next that comes up in my collection.

Now, I saw in the bug fixes of today’s update that there was something with an nVidia GPU. I have the RTX 2080 SUPER.

I have not tested the latest update. It came in after I’d finished.

I’ve also noticed that after a restart of the program, apparently it’s not cleaning up some “leftovers” as it comes quicker in the bug than with the first time.

Almost there?

The latest update 2.0.1 took clearly a lot longer before the “double face issue” eventually did show up again. As if it had been solved.

Has something been changed in it regarding this issue?

We haven’t made any changes for this specifically and our QA has not had this happen in testing. I’m fairly certain this is an issue with caching although it seems to only happen on your computer form what I can tell.

Hi Lingyu,

Maybe this particular problem only exists on my computer, but unlike issues that other users apparently seem to have (like crashes), in general Photo AI runs absolutely smoothly on my hardware.

No crashes or other issues whatsoever!

Now I indeed do have a very fast computer with “professional quality” hardware specs. Especially for heavy processing of media.

That raises the question: could my system be too fast for Photo AI? This is a question regarding CPU and GPU clock timing.

No, I have not overclocked anything. As shipped…

To me the time it takes “to bump into” the issue is totally acceptable.

As I don’t run ‘batch’ processing, I will just miss out saving a single image, and doing a restart and processing this very image is only a few second “delay.”

So I can live with it, as so far I have used it quite intensively to get to this situation.

However, I think this randomness is not really a good sign for the idea of software stability. Having been a (now retired) long-term programmer in ICT, I’m aware that software with flaws may lead to more instability in the long run.

Fair enough, I’ll check with my team if there are any further test we can run to root out the issue. It will likely be low priority for now as there are other tasks with higher importance we need to finish.

Thank you for sharing your thoughts and for your understanding of the issue.

You’re welcome. And wishing you all the best.

I have put in all this effort, because I like to support something that I consider an awesome piece of software! :+1:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.