Croping Size and Scale, Upsizing Size and Scale and Saved Image Size and Scale are totally not matched

I try to upsize image with cropping of the image.

Step 1.
I want to crop the image size with Ratio 6000:3375. (Previous version will not change this), But version 2.4.0 will change this ratio 6000:3375 to some other number like 1141:794 after I drag the crop window which is not my exact desired ratio. Suppose 6000:3375 should not change!!!

Step 2
After that, I click done on cropping, and the Upsize should show 6000:3375 in size with maybe plus minus few pixel. But result of the upsizing is 6000:3896…This is totally not the cropping ratio that I set!!!

Step 3
I continue to save. I see the saving window say that final image size is 6000:3895. but the size of the image generated is 4773:2693. which is not 6000 in width and ratio not 6000:3375 nor 6000:3896

This is totally spoil the quality of the software…

then, this new workflow is not user friendly at all, I can’t do it in 1 or 2 click if I want to reapply autopilot. Add and Remove the enhancement is totally not user friendly.


Topaz Photo AI [v12.4.0] on [Windows/Mac]

2024-03-01-03-12-45.tzlog (2.4 MB)
2024-03-01-20-48-14.tzlog (915.1 KB)
2024-03-01-21-21-41.tzlog (1.4 MB)
2024-03-01-21-42-22.tzlog (137.9 KB)
2024-03-01-21-47-9.tzlog (151.0 KB)

This is cause by 2.4.0 resize the original photo to 6000x3896 pixel, then crop the 4773:2693 from 6000:3896!!!

the sequence is totally wrong!!! suppose should crop first and resize the crop phot to 6000 in width!!!

How can I revert back to previous version??? now I can’t continue with my work…

If you would like to revert to any previous Topaz Photo AI version, you can find a list of previous installers at the following link:

Topaz Labs | Community Forums | Topaz Photo AI | Releases

If you are still experiencing problems please reach out to us at the following link:

Topaz Labs | Support Page

Just upgraded to version 2.4.0 and seems to be encountering a bug that affect the output resolution of upscaled file.

Steps i did:

  1. Load the image. The resolution is 6000 x 4000
  2. Crop the image to 2410 x 1608
  3. Apply upscaling to the cropped image to get back 6000 x 4000
  4. Save image as tif file. Program shows that it is saving a 6000 x 4000 resolution file. But actual saved tif file is 2410 x 1608.

Restarted the program and this issue still occur. This problem did not happen to me in previous Topaz Photo AI version.


Topaz Photo AI v2.4 on Windows

same issue

Browse Photo
Upload Photo
Select Crop {original ratio 51:91}
change to 16:9 and Swap to 9:16
Adjust the selection area (I want 1080 x 1920 but can only get the UI to 1080 x 1927 not matter what I do)
Click Save
Actual image saved is 1080 x 1919
closer but still not what I expected

  • actual saves vary in actual size but never match what the UI says

Just upgraded after using much older version and this one is, unfortunately, less usable as is


Topaz Photo AI [v4.2] on [Windows]

Topaz photo AI - Version 2.4.1
After selecting the ratio under Crop, the image Width is not precise as showing in Upscale window.
For example, I’m using image size: 24.6 x 36 inch, select Crop, choose a Ratio-2:3, I’d like to get 24x36 inch exactly after it crop, which is the 2:3 Ratio. But, the image Width showing 23.993 inch, Height: 36 inch. Why does it show 23.993 inch, not 24inch? I tried a few more times to crop it, I get the same result.

Steps to reproduce issue:

Steps: Upload an image, select crop, choose a ratio, after that check the image size under Upscale window.


Topaz Photo AI Version 2.4.1 on Windows
Screenshot 2024-03-16 231616
Screenshot 2024-03-16 231548

I Upscaled an image to 7200x10800px, ratio using 2:3. The output info shows 7200x10800px, and the image width and height shows 7200x10800px as well. But, after I saved the image, the image dimension becomes 7204x10804px. Why does it add extra 4px? I’d like the output image size to be exactly 7200x10800px. How to fix this?

Steps to reproduce issue:
Upload an image, Crop to selected ratio, defined Upscale width and height, then Save the image and check the saved image dimension.

Topaz Photo AI [V2.4.1] on [Window]

Is Topaz investigate and fix on Cropping and scale Up issue? Version 2.4.2 still showing same problem.

thanks