Crop & Face Recovery creates wrong output

There are issues there that you haven’t noticed. First of all, the Dimensions the in upper-right corner do not match the stated width and height. Second of all, the scale factor does not match either the stated dimensions, OR the width and height fields. Thirdly, I’d be willing to bet that the actual size of the saved photo doesn’t match either the dimensions or the width/height.

1 Like

You are absolutely right! Thanks for correcting me.
My saved image has a height of 2031px, even though the suffix appended to the filename has 2200h.

I also ran the image through GPAI v7 and it was saved correctly with a height of 2200px.

So, yes, this is yet another bug in TPAI!

Actually I reported this very fault in March.

Random floating heads that are also monochrome.

Steps to reproduce issue:

  1. Autopilot

Topaz Photo AI [v3] on [Window]

2 Likes

Just use custom crop with face recovery. If you don’t get an error, just use crop again. Changing the width/height in upscale should also be enough.


Topaz Photo AI [v3.0.2] on [Windows]


1 Like

2024-03-31-16-17-9.tzlog (336.4 KB)
Face Recovery is causing ghosted duplicates of faces in an image preview and output.

Steps to reproduce issue:

  1. Step 1 Load image
  2. Step 2 Make sure Recover Faces is selected
  3. Step 3 Crop image (note amount of cropping affects the offset of ghosted faces)
  4. Step 4 Look at preview (and output if processed)

Result: There are ghosted copies of the faces in the image.
If you remove Face Recovery, the ghosting does not occur in updated preview or output image.
Not limited to any particular image as long as face recovery runs.
If you load other images without closing or using cropping the ghosting persists if Face Recovery is on until app is closed and reopened. Then everything runs fine until you crop.
I have added an image which clearly shows what I am seeing.

M3 Macbook Pro
Mac OS Sonoma 14.3.1
App version: 2.4.2

I can confirm this behaviour:


Mac mini M1 16GB Sonoma 14.4.1

Thanks for reaching out to us here and sending in that log file. There is a task for our developers to investigate this further.

Still occurring in 3.0.2

It’s finally fixed in version 3.0.2! At least it’s working correctly for me, though I see that rej110 is still having the issue in 3.0.2.

No, not fixed at all.

Dear Topaz team.
When can we expect the fix ?

Face appears duplicated

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]


2024-06-08T21:00:00Z

I too am having double faces. In both Image opened from Lightroom, and directly in Topaz Photo. Face recognition is on.

They have known about this since V3.0 so 4 months, Maybe v.4 will fix it me I have stopped using topaz as they are obviously ignoring their user base.

There is a work round, it requires you to change the resize settings using only width after doing another resize to clear the old. I suspect it is a bugged workstream cache which they insist on not fixing.

This topic was automatically closed after 60 days. New replies are no longer allowed.