Color shift with Topaz Photo AI

After installing the latest update to Topaz Photo AI (Version 1.5), I am finding a significant color shift that occurs when sending a DNG file to Topaz from Lightroom Classic and then back again. I am sending the file using the "Plug in Extras command).The color shift does not occur until I open the file in LR. The color shift does not occur if I first open the file directly to Topaz and then save it as a DNG, and then open it in LR. Are other users finding the same results? If so, is Topaz addressing this issue? It did not occur until the latest update.

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Thanks for reaching out. What camera model is the Raw file from? Please send me an example before and after so I can try to reproduce this.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Color shift seems to be introduced by PhotoAI noise reduction on CR2 raw.

One way to emphasize this and notice it visually with ease at no magnification is to bump the exposure in ACR when opening the DNG and CR2 in Photoshop for comparison.

Its generally not glaringly visually apparent inside PhotoAI in my experience to date. But when you bring the output into post and start working on it… if you’re having a hard time reproducing this try some raw dark sky / astro imaging frames. It’ll show up.

If you want sample files LMK. They will be derived from a 6d mkii / sigma art 14mm, and the issue reproduces in PhotoAI on both an intel mac and an m1 mac in my case fwiw.

Yes please send the files to my Dropbox. You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Thanks, uploaded.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.