Chronos Audio Sync Needs a Fix

I’ve spent the last month or so trying to get a sync’d audio output from Chronos, when trying to upscale a blu ray (23.98fps) file. My conclusion is that there is an issue within the Topaz Chronos software which causes a deviation between the number of frames it should produce, and the number of frames it does produce. Due to this issue, there is no method to produce an output of a meaningful length (five minutes or so) that can be matched with the original video’s audio.

I’ve been on a long journey to reach this conclusion, I was pretty convinced initially that it was an issue with the input video - rubbish in rubbish out. I tried using ffmpeg with every command under the sun, eventually writing a script to extract frames at the correct precise time-codes and reassembling that into a new clean video file with constant perfect frame timing.

With this data, I performed a number of experiments (all outputting to image arrays, not videos):

  • Increasing the frame rate of the prores file to 60 fps.
  • Slowing down the prores file by 250%.
  • Increasing the frame rate of the prores file to 59.94 fps.
  • All of the above using the image file arrays instead of prores video files.

To compare the input and output files, I had a spreadsheet with a list of key frames from the input video, I then calculate the matching frame number in the output video and check at which frame that image actually appears, noting it in the spreadsheet. In this way, I can show the deviation in number of frames between the expected frame and the actual frame. Below is a trace of the two best attempts - both of which I stopped early as they deviated by too much to continue:

*edit: the forum won’t let my post go live with an uploaded image. It was a chart showing the deviation, the blue data set maintains zero deviation until about 6000 frames from the start then the deviation (roughly) linearly increases to 12 frames after 10000 frames, while the orange data set almost immediately starts to deviate, reaching 9 frames after 8000 frames.

Orange is conversion from 23.98 fps to 60 fps, blue is 23.98 fps to 59.94 fps. I tried converting from the image arrays and the deviation was much worse and happened much earlier.

So - there is definitely a bug somewhere in there, and there’s nothing that I as a user can do to get a useful output from the software. I’d hope that something is already in the works to get this resolved, looking around I see numerous posts about the audio sync being a problem with Chronos so it’s clearly a known issue, but often it gets written off as being a problem with the input file.