Chronos 30->60fps clips Video Length

I had a test using some drone footage recorded at 29.97fps and converted it to 59.94fps. The exported file is opened in Adobe Premier without issue. The original file is 05:27 in length. Topaz chugs away for around 6 hours, and outputs a file that is 0:54 second’s total. I was looking for settings that I might have changed to cause it to export only 54 seconds but didn’t find any.

Is there any advice for what might have happened to reduce the source file length? The file BTW plays perfect inside of Premier for Windows, and the FPS for those 54 seconds looks really good on the drone footage btw.

Settings used were Chronos Slo-Mo / FPS Conversation v1
Slo Motion =100%
Video format = MOV - ProRes 422 (Slow)
Out FPS - 59.94

Can you run Mediainfo on it with “view” set to “text” and paste the output here?

Yes I can: mediainfo from both files below:

ORIGINAL:
General
Complete name : H:\TEST DELETE LATER\DJI_0057.MP4
Format : MPEG-4
Format profile : JVT
Codec ID : avc1 (avc1/isom)
File size : 3.81 GiB
Duration : 5 min 28 s
Overall bit rate mode : Variable
Overall bit rate : 99.8 Mb/s
Encoded date : UTC 2021-05-17 01:08:50
Tagged date : UTC 2021-05-17 01:08:50
Comment : DE=None,SN=, Type=Normal, HQ=Normal, Mode=P
xyz :
xsp : +0.40
ysp : +1.10
zsp : +0.10
fpt : -0.70
fyw : +175.50
frl : -6.90
gpt : -12.90
gyw : +2.80
grl : +0.00

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings : CABAC / 1 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 1 frame
Format settings, GOP : M=1, N=30
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 5 min 27 s
Bit rate mode : Variable
Bit rate : 100.0 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 29.970 (30000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.402
Stream size : 3.81 GiB (100%)
Title : DJI.AVC
Language : English
Encoded date : UTC 2021-05-17 01:08:50
Tagged date : UTC 2021-05-17 01:08:50
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709
Codec configuration box : avcC

Text
ID : 3
Duration : 5 min 28 s
Bit rate mode : Constant
Bit rate : 2 048 b/s
Stream size : 82.0 KiB (0%)
Title : DJI.Subtitle
Language : English
Forced : No
Encoded date : UTC 2021-05-17 01:08:50
Tagged date : UTC 2021-05-17 01:08:50

Other
Type : meta
Bit rate mode : Variable
Default : No

TOPAZ EXPORT:
General
Complete name : H:\TEST DELETE LATER\DJI_0057_chr-1_1percent_slomo_59_94fps.mov
Format : MPEG-4
Format profile : QuickTime
Codec ID : qt 0000.02 (qt )
File size : 63.2 GiB
Duration : 5 min 27 s
Overall bit rate mode : Variable
Overall bit rate : 1 658 Mb/s
Writing application : Lavf58.20.100

Video
ID : 1
Format : ProRes
Format version : Version 0
Format profile : 422 HQ
Codec ID : apch
Duration : 5 min 27 s
Source duration : 54 s 221 ms
Bit rate mode : Variable
Bit rate : 1 658 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 59.940 (59940/1000) FPS
Color space : YUV
Chroma subsampling : 4:2:2
Scan type : Progressive
Bits/(Pixel*Frame) : 3.336
Stream size : 63.2 GiB (100%)
Source stream size : 63.2 GiB (100%)
Writing library : fmpg
Language : English
mdhd_Duration : 327561

What software is only showing/playing 54 seconds? Could you try opening it in avidemux?

I just downloaded AVIDEMUX, and it displays the entire file, and lets you play it.
I am using the Adobe Creative applications to edit the Video and it only shows me 54:09 of the video. This is true for Premier, Rush and After Effects.

In looking at the details from MediaInfo it says the file is 54:09 also; It seems to me that Topaz is writing incorrect Metadata to the file? Adobe might be reading the “source duration” metadata as the length of the video.

Here is the example:
Duration : 5 min 27 s
Source duration : 54 s 221 ms

I’m using Avidemux to encode the file to the MP4 right now, and see if adobe can read the while file. But this is for testing as I’m not prepared to do this for a production workflow (too many conversations). I feel like this is a minor bug in the export format with Topaz that could be an easy fix, as the file itself appears to have all the required data for the full video.

Has anyone tried this with a file the same length as the source I used for my test?

There’s a few things you could do to work around this:

  1. You can repackage the mov as an mkv using mkvtoolsnix. This method would avoid transcoding to ProRes again avoiding a quality reduction and it would be pretty fast. I think it would recalculate the duration

  2. There might be a way to remove the “Source duration” value from the video metadata with ffmpeg without transcoding, though I’ve never tried to do that.

  3. You can use ffmpeg to do a straight copy and generate new metadata and see if it correctly sets the “Source duration”

  4. Try the ProRes 422 HQ fast option. Just a note, I have no idea why it says “fast” vs “slow” for the ProRes 422 standard. The HQ is better quality, uses a higher bitrate, but I’m pretty sure they take the same amount of processing power to decode or encode.

  5. So you are using ProRes because you want high quality, you could also try H264 with CRF=0 which is lossless, though it’s not as compatible.

I’ve never use slow motion on VEAI how does it slow the video down and what does a frame rate conversion from 29.97 to 59.97 have to do with that?

I am not sure I understand your question fully. The frame rate conversation I am doing is not to slow down the video, but rather double the frames (it appears to be making a new interpolated frame for the appearance of exceptionally smooth footage).

I have used optical flow within premier before with mixed results. This is my first attempt at using Chronos to frame double. It seems to create a very smooth video for the drone footage I had. Most of what I shoot is in 60fps, with the exception of one drone I use, which is max 4k@30. I was using the

Chronos engine to frame double so it fits with the other footage.

I have not tried Chronos to do a slow-motion sequence yet. I suspect the intent with the slow-motion is to keep the framerate but add in new frames. The result if you wanted to do a 2x slow-motion, would be a source clip that was 10 seconds @ 30fps would end up being 20 seconds at 30fps with new interpolated frames.

Not sure if that answered your question on the relation of slow-motion to conversation of 30->60fps, hopefully it has.

First off thanks for your help/advice.
The idea with ProRes was both to have lossless, and it’s an extremely easy codec to edit within premier. H264/H265 is a bit of trouble for editing, so if I can avoid it, I do. If I work on a big project, I tend to let media encoder convert to prores to make editing easy and more responsive.

I’m going to try a few other samples with different settings within Topaz and see if I can get it to work without additional steps. It’s possible there is small bug, and it will be fixed soon anyways, I may just wait and see. I don’t have a pressing project right now that requires it so waiting might work out okay.

I like the idea of ‘repacking’ / changing the container and that might recreate new metadata that would fix it maybe. I may play around with that just to see if it works.

In a pinch I guess using Avidemux would allow me to work around the problem short term.

If this is a DJI mini2 drone there’s a new firmware that’s you record 1440p at 60fps.

As a matter of fact, this one is. I have a great deal of footage recorded prior to 60fps being available. I plan to run some tests at 60fps@1440 and use Topaz to upscale the footage, which helps with the noise in image from the mini2 also. But this footage I’m working with was all recorded in 4k@30fps. I suspect I can get something to work out and look good enough to match the footage from my Inspire. Not to mention the Mini2 at 30fps is not smooth enough but topaz really helps it. I’m really impressed how it turns out after to conversion to 60fps with Chronos.

Do you know what’s in the 3rd track that just says “meta other”. So DJI embeds GPS information , if that’s it I wonder if it’s getting the incorrect timestamps from that somehow.

So, are you saying VEAI will work well doubling frames, just for the purpose of going to 60fps? Because if doing so results in a longer duration file (or any deviation, really), the entire endeavour becomes kinda useless (at least to ppl like me, who generally love audio with their films).

Thx.

Avidemux will work, but another option is to render to image sequences, TIFF or PNG, that you can just tell Premiere (or other video editing software) to interpret as 60 fps. You do lose audio, but it’s not difficult to sync it back up manually if necessary.