Can't Apply AI clear, nothing happens

When I use AI Clear, either coming from Photoshop, Lightroom, or Topaz Studio, after using AI Clear, I hit Apply and the adjustment disappears. It shows on the first photo in the thumbnails along the bottom, but the photo where I hit apply shows nothing happened. I can do other adjustments and then Apply and all those adjustments are just fine.

It worked until I upgraded to the newest Topaz Studio. I have 1.13.1.

By hitting apply you have essentially flattened the image (or applied AIClear to the image) and that (the AICleared image) has now become the base image you are starting with for the next round of editing. The reason why it is not a bad idea to hit the apply button once you have the image how you want it from AIClear is that if you were to do further adjustments on the image with the AIClear adjustment, Topaz Studio has to keep calculating with AIClear each time something changes and this re-calculating can really slow down the process.

NOTE: if you want to have another copy of the image with the AIClear adjustment still functioning you can use “duplicate” option near the apply button and the adjustment or all adjustments (if you have many) are copied.

Apply doesn’t return to PS, it will apply the adjustments and create a new version of the image with those adjustments applied.

Use OK to update the photoshop layer passed with your adjustments and return to PS.

I know what Apply does, what is happening, my original photo, first one in the tray, I do my AI Clear adjustment, then I hit apply, I look at the second image in the tray and here is NO AI Clear applied. If I do AI Clear, hit ok to return to Photoshop, again, there is NO AI Clear adjustment on my image. It is not keeping the adjustment on my photos.

Now, If I do any other adjustments (other than AI Clear), then hit apply, the next image in the tray shows all the adjustments.

This is only happening since the newest AI Clear update, before the update, it worked perfectly after hitting Apply.

Please raise a support request stating your computing environment, PS version and GPU details. Note that I have CS6, latest Studio on Windows 10 and don’t see this behaviour.

Also make sure your GPU drivers are up to date.

I also have this issue since recent update. My workflow tends to be use of AI Clear (which is great) then hit apply (all from Studio). I have tested this on a number of images and ensured its not my machine. It is very evident that AI Clear has suddenly stopped applying when hitting that button. I have reported this (though there seem to be issues with that currently).

Have done further testing - I’m not certain but I don’t think AI Clear is being properly processed even when (following more editing with other adjustments) being saved as a JPEG.


Using the “Apply” button will apply the adjustments you have to the current image and create a new image showing those adjustments, which you can then work on or save as a new image to disk using save as.

If you are using Studio as a plugin from an external application such as Lightroom or Photoshop, you must use the OK button at the bottom right as the recent Apply you used wont be returned. Again you have to save it to disk using save as.

Hi, Thanks, but although I’m aware of the expected behaviour, it simply isn’t doing it. Hitting apply after performing AI Clear is not delivering a flattened version in order to continue editing. Indeed, even if I continue with other adjustments without hitting apply it is not retaining the adjustment from AI Clear. This is with the freestanding Studio version.

Make sure you view the resulting image at 100% for a comparison.

If it still doesn’t use “Help-> Reset Local Database” after reading this Help article, especially the warning about your presets you have created:

Thanks again - tried that (much appreciated), but it has not resolved it. I have also tested to see if it works when used as a plug-in, but it does not work there either. It certainly used to work, both as stand alone studio and as plug-in.

I just uninstalled Topaz Studio, reinstalled it, and when I opened it as a free standing program, used AI Clear, saved the file, left it open in TS, opened the saved file in Photoshop and compared them, AI Clear is not being saved to my photos. I also tried other adjustments, saved, compared files and the adjustments showed up. It seems, only AI Clear is not saving.

I just upgraded my Graphics card (Nvdia 900 series), and tried again. No go. Is there going to be a fix for this, as paying for something I can’t use is not fun. Thank you

Just to let you know, I raised this problem with Topaz support guys. They have informed me that they’re currently working on it. Its an amazing programme when its working properly so hopefully they’ll sort this out before too long.

Thanks for letting me know. When I have tried to use AI Clear, the results are phenomenal. I just wish it would save or take the results back to PS. I’ll be waiting for the update.

Just a reminder folks, we are tracking many issues on all of our products, but we are a very small team, and cannot work on everything at once. Some issues that are reported to us may take a while to fix, and we’re happy to refund any non-working products if that’s an option. If it’s not, we’re happy to provide store credit. Unfortunately, support cannot fix things, we can only communicate the situation. We have a LOT of updates and changes planned in the next several weeks, and there’s going to be a lot of activity. Please try to keep in mind that activity in an area that you aren’t interested in does not mean we are not actively working on an area of our products that you are interested in. Feature requests, feedback, bug reports, crashes, etc., are all considered for each update, and we do what we can for each sprint (agile). We’re working on refining the support-to-development problem reporting process, and will be growing our support team a bit, soon, to react more quickly. We expect a number of issues in several products to be addressed soon, and several issues are just waiting in the queue to be addressed once the next (and following next) batch of updates are tested and released.

Thanks for your patience. It really helps to know our customers are so passionate about our work, especially considering that we only have 15 people on staff and every one of us gives 100% every week to make things happen. :heart:


Thanks Joe - that was really well put. For me (I can only guess for others too), AI Clear is just so astonishingly good that I don’t like being without it ! Mind you, I can say the same for other Topaz products too. Some of the work you guys have produced recently - wow!

1 Like

For once I’m reading these forums and I’m having the same issue with Al Clear. It applies but when I the image returns to PS CC, Al Clear is missing. All other adjustments are there. Finally I opened Topaz Studio as the stand alone product and applied Al Clear to my image and it works. I’m pretty sure this is not normal, and hopefully this bug will be fixed soon.

1 Like

I as well lost AI Clear Functionality. One day it worked flawlessly the next day the adjustment stopped being applied to the image either via LR or Topaz standalone. I tried all the remedies as suggested but nothing works. I hope that everyone who has purchased this product and experienced this failure writes in these forums so that if the issue is wide spread a higher priority can be applied to the fault. I can appreciate the difficulties that a small team can have in addressing technical issues but that’s an internal corporate problem. From a customer perspective I bought the tool in good faith and have an expectation that matters will be resolved within a reasonable time. Lets hope that new hires can help to expedite resolution to these issues since we all love AI Clear. If not resolved soon I may have to remove you from my valentine card list.

Did you raise a support request? The link is at the Need Help? link above, choose Studio.

I raised the issue via email and have corresponded in that manner. I can also create a support request as you have suggested. Tks