Can't activate Photo AI 1.5.1 on my Mac

I downloaded Photo AI 1.5.1, then shut down LRC and went through the installation process with no error messages. All seemed fine.

Launched the application and the Activate dialogue window pops up. I click on Activate and it switches to the browser (Chrome) and Authenticates with a message that the tab will close after a few seconds. Tab closes, but Topaz AI stays stuck on the dialogue window with the Activate button showing “Authen ticating…”.

If I wait long enough it switches to demo mode. I checked my subscription and it is Active.
I then tried rebooting and relaunching the application, but no luck.
I went into Chrome settings and deleted all the cookies related to Topaz Labs, tried again and, aside from having to log into the Topaz Labs site, still the same happened: Stuck on Authenticating…
Then I tried rebooting and re-installing, still the same behavior.
Running MacOS Monterey (12.6)
MacBook Pro.spx (6.5 MB)

Please follow the instructions in this article:
Topaz Photo AI Freezes on Importing Image (Mac)

1 Like

Thanks, that worked!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.