Cannot save image in Sharpen AI v2.0.5

When I open a tif file, select, “sharpen”, “auto mode” and I press “save image”, but no action is done.

It seems OK for me Win 10, you should get this dialog when you press Save:

I have an older iMac running High Sierra v.10.13.6
I initially installed Sharpen AI v2.0.3 which got upgraded to v2.0.5
I no longer get the “Save Image As” dialog box whether Im processing Tiffs of Jpgs. Nor do the save files have the suffix applied as checked in Preferences.
Whats going on?

Are you running in standalone mode or as a plugin to PS or LR?

Im using it as a standalone - is there a way that it could be in plugin mode by mistake?
Thanks for the response…

OK - update!
It seems that when I use Finder to “Open With” command to launch Topaz Sharpen AI, Topaz does not give me a menu option for “Save As” nor if I just hit the Save button I don’t get a Save As dialog box - it just saves the file without appending a suffix etc and closes.
However, if I Drag and Drop a file into Topaz, everything seems to be OK!!! Apart from “freezing” after I had processed a TIF successfully it wouldn’t open a Drag and Dropped JPG. I had to close it and relaunch. Still progress!

That is right, you just need to change your workflow as if you start from ANY other application you will not be offered the Save as options, your file menu will look like this:


This will include Finder, Windows Explorer, Adobe Bridge, any Finder/Explorer like replacements and calling from any other applications that have a Edit with function.

This is the exact same experience that I have been having lately!

Please clarify: Does “Standalone” mode mean everything must be opened through Topaz Labs? Or, I can open directly with Sharpen AI but the app must be opened first, or the image must be dropped into it?

And does this mean that the images that I’ve attempted this with have been overwritten with the sharpened final result (because the suffix wasn’t appended), or were they just not saved at all?



  • Becky

Firstly, if you open Sharpen AI in plugin mode such as from Lightroom, PS, Studio etc., the image you pass will be updated with the sharpening you select to be applied.

In standalone mode the image is opened from Sharpen AI and you have the option to save the output in another file.

Thanks, Don, for the prompt response. I’ve changed my workflow and can save images now if I take the right steps. I appreciate the clarification.


  • Becky
1 Like

I have a similar problem. Pressing the Save Image button bottom right and nothing happens. No dialogue box appears to choose file type etc. The app seems to freeze. The only way out of this is to press X to close the app and then say ‘no’ in the exit dialogue box. The app wakes up but still cannot use the Save Image button:

  • I downloaded 30 day trial version two days ago (AI v2.0.5)
  • The app is impressive - it can really salvage slightly soft photos
  • Worked well last two days, but today I cannot save/export the result
  • I use the app in standalone mode
  • I click on the Open image button and select my Tiff
  • I choose Stabilize and Auto and it previews well
  • But nothing happens when I press Save Image

Any ideas?


To clarify the post above - I open Topaz Sharpen AI by clicking the shortcut icon on my desktop direct - not by launching it via another application. It is even a problem if I click directly on the application.

I then tried to launch it from DXO Photolab 3 and that works. So somehow it thinks it is a plug in when it is not when I try to use it in standalone mode.


Same problem with running Sharpen as a Standalone App - will not shave or save as but works perfectly through Topaz Studio. Still waiting for a fix from Topaz Tech support - very frustrating.

Please go to Help-> Graphics info press Copy and paste the info here.

Are you opening an image through the open dialog or dragging it into the icon.

Via the Drop down menu to open image file.

Please go to Help-> Graphics info press Copy and paste the info here.

As requested:

Application & Version: Topaz Sharpen AI Version 2.0.5

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GT 610/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 388.13

CPU RAM: 32711 MB

Video RAM: 1024 MB

Preview Limit: 1767 Pixels

Thankyou, please open an image then press Reset in Advanced preferences and update the preview. It should recalibrate the preferred mode. Then post a screenshot of the preferences here:


What happens when you press Save image? Does this dialog pop up?


DxDiag29-5-20.txt (89.4 KB)

I’m running Win 10

NVIDIA GeForce GTX 1050 Ti
Win 10
Sharpen V2.0.5