Cannot Proceed. Error: plug-in has crashed

I am using an iMac with Ventura 13.6.7. While using PhotoShot Elements 2021 and trying to use Topaz I get the error message “Cannot Proceed. Error: plug-in has crashed.”

Steps to reproduce issue:

  1. Step 1 - In Photo Elements Editor I click on Filter and select Topaz Labs.
  2. Step 2 - Topaz opens and starts to process the photo then in seconds crashes and gives the error message.
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please follow the steps below to reset your Photoshop Elements plugin.

  1. Close Photoshop Elements fully.
  2. Run the Topaz Photo AI installer again. Get a new one from the downloads page: Topaz Labs Downloads
  3. Open Photoshop and check the Filter > Topaz Labs > Topaz Photo AI plugin again.

Let me know if those steps get it working again.

Topaz Labs Documentation | Topaz Photo AI | Plugin | Photoshop & Photoshop Elements

If it does not, open Topaz Photo AI, go to the menu bar on the top and click the ’ Help > Open Log Folder ’ menu option. You should be able to attach the whole folder to this email to send to me.

tpaiLogRequest

Steps1 - 3 did not work. I tried sending all the logs and the email was rejected. I will try with just a few now.

Monte Zillinger
817-909-8635

Filter Plugin Log.txt (10 MB)

If you are having trouble attaching the log files you can securely submit your files(s) to my Dropbox using the link below. Make sure to send me a note to let me know you sent something. :slight_smile:

Dropbox File Request

I just dropped 13 files into your dropbox. Thank you.

Monte Zillinger

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

First please make sure that you have Photoshop Elements fully closed before proceeding

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Unfortunately this did not work.

Monte Zillinger

Let’s try adjusting your AI Processor, you can do this by going to Preferences > General and setting the AI Processor to CPU.

I will note that Intel CPU Mac devices are slightly underpowered for AI processing and will have slower performance. We have some more information on our Topaz Labs Documentation page that I will link below for your review:

Topaz Photo AI | System Requirements

Many users with Intel MacOS machines have reported that Topaz Photo AI v2.4.2 is most suited for their needs and experiences better processing times. I have included a link to that previous version below if you would like to revert to this version for your machine:

Topaz Photo AI | v2.4.2 | Mac Installer

That worked!

Thank you!

Monte Zillinger

1 Like

Well that was a very short lived fix. I was gone for 5 days and today I came home and tried to use the Topaz plug in with Photoshop Elements. It crashed again.

Monte Zillinger
817-909-8635