[Bugs] Custom Setting gives almost no artifact result? (VEAI uses wrong models)

UPDATE 3: This method/bug is no longer working. Topaz fixed it. You don’t have to worry about it anymore.
UPDATE 2: I believe this is some kinda drivers issue. I might be wrong but I still have no answer for it.
UPDATE 1:

  • When I use 4K UHD 200% with 4K output, it uses this model (ahq-v11-fnet-fp16-576x672-4x-ox.tz)

  • When I use Custom setting standalone with 200% output, it uses this model (ahq-v11-fnet-fp16-576x672-2x-ox.tz)

Appearently, I can see VEAI is using wrong models. At least on my machine with dual RTX 3090 (All GPU option).

I know it sounds weird, but I’ve been using VEAI for months with Artemis artifacts here and there. I know a lot of people dealing with things like detail smoothout, or weird faces, or artifacts in general. But here I found the solution and I would like to ask everyone to test it out. I’m sure that it will blow your mind.

Normally, we all pick Full HD or UHD options for videos and then let it run right? Some users will adjust the custom settings AFTER you pick Full HD or UHD right? You’re not alone, I did that all the time. But why I highlighted AFTER? Let me explain.

I believe that VEAI has some presets for UHD and Full HD that are “incorrectly” upscale the pixels. Since not every video has the same quality, these FHD and UHD options basically just try to guess missing pixels. I don’t know if it’s true, I might be wrong, but I’m just trying to explain my thoughts about it.

Today, I tested something that I haven’t tried before. I picked Custom setting option FIRST. Then choose 100-200-400-450% upscaling. And you know what? Almost no artifacts for every model, including Artemis and Dione models. It’s just like… magic. No over detail smoothout, no artifacts (except grass and trees if you zoom in, but less visible than before). This is AMAZING. I’m not sure how to explain it, but the developers will know what I’m talking about. If you (the developers) read my post, please give me and the others an explanation. This is very interesting to me to test out every single model again with this method. You might think it is the same when you pick Custom setting only vs FHD/UHD + Custom setting, but it is NOT. Test it out yourself and you will see what I mean. I was upscaling DVDs with Gaia CG the most, because other models just gave me a ton of unwanted artifacts. But this method just solved 90% artifacts I had. Trees and grass are less “over-upscaling”, skins without detail smoothout, but 200% is much better than 400% for footages that have trees and grass. But still very very precise.

After pick the settings, look at the model indicator on the lower left corner of the video. It should show “Artemis High Quality v11 ERR” or something like that. If you choose FHD or UHD first, it will show “Artemis High Quality v11 4K/HD/200%/400%/100%”. It must be ERR to work perfectly.

Now I just go ahead and test every single model again to find out what is good for DVD and Blu-Ray contents again. I will wait for you guys replies and see if I’m right. If it doesn’t work for you, it’s okay, but please try again with other footages. I believe this method will change your mind about VEAI from now on.

2 Likes

Can you post before/after screenshots?)

1 Like

I will try again later and let you know soon.

Here are the results between UHD and ERR option with the same settings except the Custom setting and 4K UHD setting. The differences are big enough to see that they are not the same when they “should” be the same.

edit: the second picture was Artemis MQ 12 comparison, I mistyped the file name, not MQ 11

You’d need to tag Taylor or send this to them directly.

Im using v2.2.0 on Windows, Fresh Install, Default Settings. Nowhere in the lower left corner it says ERR or FHD. Could you please provide a step-by-step guide on what you do?

Is it as such?

  1. Load a video
  2. Select Custom SETTINGS
  3. Choose 100% or 200% or 400% (Lock Output Size ON)
  4. Pick a Model

Because I dont see the ERR thing anywhere on screen. It always display the full model name without any suffix

Try to save the settings as default and restart the app.

I approve this difference.
Here what I’v found:
In my case I’v tested Artemis LQ model. Process monitor shown that this model file is used: alq-v12-gnet-fp32-576x672-1x-ox.tz

The difference occures when you select HD 1920x1080 model.
For example.
Select custom or 100% denoise/deblock setting. Save it as default. Restart.
Then open your video and make some frames to image files.
For 100% custom & 100% denoise files will be identical (by bytes).
Your model will be in memory now (loaded only once).
Now select HD 1920x1080 model. And you will get different results (lets call them result2).
If you will select 100% custom or 100% denoise after this - results will be same as for HD1920x1080.
So it looks like by selecting HD1920 some parameters are initialized and they are not changed back if you select custom or denoise after.

If you load program with cusom/denoise default settings. Then you will not start processing. And just only switch to HD1920 profile and then right back to custom or denoise. And then start processing. You will get same results as on HD1920 profile.

1 Like

I believe that VEAI uses wrong models for the presets. Instead of x1, it might use x2 or x4 that destroys the video for sure. If the right models are selected, the artifacts and smoothout will be less to none. This is a huge deal when most users don’t know what model (the actual one) are being used. This needs to be fixed asap because it affects VEAI in the worst way.

Could you provide step by step detailed instructions to trigger the “ERR” phenomena? I’ve seen it once and am unable to reliably reproduce what you’re describing.

You need to pick Custom setting first. Then save it as default.
Restart the app. Then open it again.
When you open it, just run it, don’t choose the HD UHD presets.

In my case the same model was used each time (custom/denoise/hd). And it was loaded into memory only once. But I was not using enlargement (only 100% scale).
Btw custom setting differs from hd 1920 because it resize image differently (only by scale specified).
Maybe its a bug too of some sort.
For example if I have source 720x480 and set 1920x1080 in custom (but scale 100%) the image is not enlarged - just black bars added to make output 1920x1080. I think it should be changed so that we specify enlargement using pixels and not scale. Because we target some known definitions and not some weird % scale.

1 Like

I believe the presets are like this:
HD 720p default model x1
HD 1080p default model x2
4K UHD default model x4

Instead of using correct scaling, it uses its default models, not using the original resolution to pick the right models like Custom setting does.

I was able to randomly?! get Gaia HQ ERR, but am unable to recreate that setting. IIRC, First I choose custom settings 225%/2.25x -> set CRF to 18 and grain to 1.2 -> saved as default and quit -> Reopen and only choose Gaia HQ and it said Gaia HQ ERR. I then restarted to see if it stays like that but sadly it didn’t.
So viktorz3008 how are you able to reliably get the ERR setting? Would you mind recording a short video showcasing it?

I did just exactly like you did. I was able to use ERR correctly anytime I want (I just don’t know why). If I want 200%, it will be 200%. If I want ERR, I change to Custom setting alone. I have no idea why it’s harder to do so on some users’ machines, but for me, it’s kinda easy.

1 Like

Alright, I’ve been upscaling a 2.5h Movie for the last 18 hours (2 more to go) with Gaia HQ, afterwards I’ll try to recreate the ERR mode or whatever it is ^^. By the way, what about the output? Should I change it to TIF or keep it at MP4 before saving it as Default?

Output doesn’t matter after all.

1 Like

Does Custom have to be these settings? Can I choose, for example, 300%?

It seems to be 100% 200% and 400% only on RTX A6000. On my RTX 3090, I can achieve 450% ERR. That’s weird.

Edit: Nevermind, 450% on RTX A6000 now. I believe this is more like some kind of drivers issue.

Hi… viktorz3008, what version of Topaz are you using? For custom setting you can use the custom presets like 100 / 200 / 400 or you can write your own numbers like 225 / 190 etc?