Bug: Crash after returning from export (Photo AI 3)

Crash/freeze after exporting file (with overwriting). I have to restart the app every time I export. So the app is useless now. That is really bad because I need/use the app every day for my customer projects.

Steps to reproduce issue:

  1. Open photo & edit
  2. Export (overwriting file)
  3. Crash (dark screen, freeze, some buttons are missing)

Topaz Photo AI 3.0.3 on MacOS Sonoma 14.5. Mac Studio M2 Max

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this thread.

If you would prefer you can securely submit your files(s) to my Dropbox using the link below. Make sure to send me a note to let me know you sent something. :slight_smile:

Dropbox File Request

Logfiles.zip (1.7 MB)

Thanks for sending in those log files. Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Thanks for your help. I did all of your recommended steps - same bug. But now I activated to close the window after export and that works fine yet. Nevertheless it would be great if you could fix the bug with one of the next updates.

Could you try the following build to see if the problem is still occuring:

Topaz Photo AI Alpha | MacOS

If the problem is still present please send in log files from this build so we can investigate further.