Black Screen

I installed Topaz Photo AI v1.3 on my 2012 iMac running Ventura via OpenCore Legacy Patcher. When I open it, all I get is a black screen.
Note that other Topaz programs (Sharpen AI, Denoise AI and Gigapixel AI) work fine.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

1 Like

Hi @leodreas, is this the first time you’ve tried to install Photo AI on this system?

Since OpenCore Legacy Patcher allows booting of macOS on older computers that are no longer officially supported by Apple, I’m not certain this computer will meet our minimum requirements in terms of hardware and may even run into conflicts because of the OpenCore tool itself.

I’ll pass this over to our Photo AI specialist to be certain, but please include your Mac system profile for us to check.

How To Obtain Your System Profile (Mac)

iMac.spx (6.6 MB)

Additional testing indicates that the other Topaz products I have crash when a picture is loaded.

Please open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option. Upload all the logs files that you can see in the window that opens to my Dropbox.

Please be sure to send me a note to let me know you sent something.
Dropbox File Request

To my knowledge, OpenCore Legacy Patcher is not supported with Topaz Photo AI. I can check the logs with my team to see if there is a workaround, but it’s likely that it will not work on this computer.

This is bad news and would mean I had to buy a new Mac in order to run Ventura (and so TPAI) on supported hardware

Just a quick note. Open Core Legacy Patcher 0.6.5 resolved this issue on my Mac Pro 5,1 tonight.

I also thought that this issue had been resolved by the latest version of OCLP, but then Topaz Photo AI crashed while it was analyzing the photo I had loaded. I tried again, with several different photos but no luck.
It occurred to me that I could make an adjustment in the Preferences. I selected General and then set the AI Processor to CPU rather than Auto. After saving this new setting, I was able to process photos without any problems, except that it seems to be working slower. Conclusion: the setting for the graphics card provided by OCLP is very likely the problem.

@sindbad.tsf @bob.dempsey @leodreas
Thanks for checking and letting me know the status. We did not build Topaz Photo AI with support for Open Core Legacy Patcher so while it may work this is not officially supported and could have issues.

For example, it sounds like the main issue is that the GPU is not used correctly with this setup. The logs I checked showed that the graphics card could not create the GUI in the previous version of OCLP.

However, the new version of OCLP seems to be able to run Topaz Photo AI if the graphics card is not used.

Let me know if you have any questions about this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.